aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-04-30 07:29:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-04-30 07:29:07 +0000
commitae60837282100fc23ab04204c26b7996358faae1 (patch)
tree3df56012e6fe263020d92ab12eb0f221187ac2de /accessibility
parent4f5868bcf21f0c59e8fff2e2bd7446966fce5fd2 (diff)
downloadports-ae60837282100fc23ab04204c26b7996358faae1.tar.gz
ports-ae60837282100fc23ab04204c26b7996358faae1.zip
Notes
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/gnopernicus/Makefile5
-rw-r--r--accessibility/gnopernicus/distinfo4
-rw-r--r--accessibility/gnopernicus/files/gnopernicus-mag-config66
-rw-r--r--accessibility/gnopernicus/pkg-plist2
4 files changed, 73 insertions, 4 deletions
diff --git a/accessibility/gnopernicus/Makefile b/accessibility/gnopernicus/Makefile
index 3f9aa339d42d..0795da8707e8 100644
--- a/accessibility/gnopernicus/Makefile
+++ b/accessibility/gnopernicus/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnopernicus
-PORTVERSION= 0.10.7
+PORTVERSION= 0.10.8
CATEGORIES= accessibility x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.10
@@ -29,12 +29,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAKE_ENV= SED="${SED}"
GCONF_SCHEMAS= brlmonitor.schemas gnopernicus.schemas remote.schemas
-SHLIB_VERSION= 7
+SHLIB_VERSION= 8
PLIST_SUB= SHLIB_VERSION=${SHLIB_VERSION}
post-patch:
@${REINPLACE_CMD} -e 's|^F||' \
${WRKSRC}/help/braille_monitor/C/brlmonitor-C.omf \
${WRKSRC}/help/braille_monitor/es/brlmonitor-es.omf
+ @${CP} ${FILESDIR}/gnopernicus-mag-config ${WRKSRC}/gnopi
.include <bsd.port.mk>
diff --git a/accessibility/gnopernicus/distinfo b/accessibility/gnopernicus/distinfo
index b3e9219c5d91..1e60532e35b8 100644
--- a/accessibility/gnopernicus/distinfo
+++ b/accessibility/gnopernicus/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnopernicus-0.10.7.tar.bz2) = 542be3fb46c3e8f335513ec5a4d3de74
-SIZE (gnome2/gnopernicus-0.10.7.tar.bz2) = 2029015
+MD5 (gnome2/gnopernicus-0.10.8.tar.bz2) = 331093bfb76f4865d6c0cebe8291063d
+SIZE (gnome2/gnopernicus-0.10.8.tar.bz2) = 2034246
diff --git a/accessibility/gnopernicus/files/gnopernicus-mag-config b/accessibility/gnopernicus/files/gnopernicus-mag-config
new file mode 100644
index 000000000000..ae13fd323dcd
--- /dev/null
+++ b/accessibility/gnopernicus/files/gnopernicus-mag-config
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+GNOPI_RES_X=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/display_size_x`
+GNOPI_RES_Y=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/display_size_y`
+
+OLD_SOURCE=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/source`
+OLD_TARGET=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/target`
+
+SPLITSCREEN_RES_X=`expr $GNOPI_RES_X / 2`
+
+
+if test $# -eq 0; then
+ echo "Usage: gnopernicus-magnifier [-s] [-t] [[-F] | [-S]]
+ -s source_display Sets the magnifier source display screen. Eg (:0.0)
+ -t target_display Sets the magnifier target display screen. Eg (:0.0)
+ -F Sets the magnifier placement so it will cover the
+ whole screen (Fullscreen).
+ -S Sets the magnifier placement so it will cover the right
+ vertical half of the screen (Vertical Split Screen).
+Note: When doing a full scren magnification, the source/target screens
+ have to be set before the full-screen mode and their values have to be different"
+exit 1
+fi
+
+while getopts ":FSs:at:b" Option
+
+do
+ case $Option in
+ F)
+ echo "FullScreen"
+ if test "x$OLD_SOURCE" = "x$OLD_TARGET"; then
+ echo "Source and target are the same.Please set them different first"
+ exit 1
+ fi
+ echo "Setting fullscreen mode."
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_left 0
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_top 0
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_width $GNOPI_RES_X
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_height $GNOPI_RES_Y
+ ;;
+ S)
+ echo "Setting vertical split screen mode."
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_left $SPLITSCREEN_RES_X
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_top 0
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_width $GNOPI_RES_X
+ gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_height $GNOPI_RES_Y
+ ;;
+ s)
+
+ echo "Setting magnifier source screen value from [$OLD_SOURCE] to [$OPTARG]"
+ gconftool-2 --set --type=string /apps/gnopernicus/magnifier/schema1/generic_zoomer/source $OPTARG
+ OLD_SOURCE=$OPTARG
+ ;;
+ t)
+
+ echo "Setting magnifier target screen value from [$OLD_TARGET] to [$OPTARG]"
+ gconftool-2 --set --type=string /apps/gnopernicus/magnifier/schema1/generic_zoomer/target $OPTARG
+ OLD_TARGET=$OPTARG
+ ;;
+ *)
+ echo "Not handled!"
+ ;;
+ esac
+done
+shift $(($OPTIND - 1))
+
diff --git a/accessibility/gnopernicus/pkg-plist b/accessibility/gnopernicus/pkg-plist
index d8ca74552d72..74915167f0c8 100644
--- a/accessibility/gnopernicus/pkg-plist
+++ b/accessibility/gnopernicus/pkg-plist
@@ -1,4 +1,5 @@
bin/gnopernicus
+bin/gnopernicus-mag-config
bin/srcore
etc/gnopernicus-1.0/translation_tables/de.a2b
etc/gnopernicus-1.0/translation_tables/en_US.a2b
@@ -15,6 +16,7 @@ include/gnopernicus-1.0/libsrs/srs-xml.h
include/gnopernicus-1.0/libsrutil/SREvent.h
include/gnopernicus-1.0/libsrutil/SRMessages.h
include/gnopernicus-1.0/libsrutil/srintl.h
+include/gnopernicus-1.0/libsrutil/sru-debug.h
include/gnopernicus-1.0/libsrutil/util.h
lib/gnopernicus-1.0/libbrl.a
lib/gnopernicus-1.0/libbrl.so