aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-02-16 17:22:05 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-02-16 17:22:05 +0000
commiteb384d41a1ba18d2579bc52776f2420aa6cb76f5 (patch)
tree24fe006d1d4051c6b1f6964b268b749c1c6684cf /accessibility
parent2f014352ef1321b3bf5ecbd6be93eb5545633a83 (diff)
downloadports-eb384d41a1ba18d2579bc52776f2420aa6cb76f5.tar.gz
ports-eb384d41a1ba18d2579bc52776f2420aa6cb76f5.zip
Notes
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/Makefile1
-rw-r--r--accessibility/eflite/Makefile62
-rw-r--r--accessibility/eflite/distinfo3
-rw-r--r--accessibility/eflite/files/es.conf.sample7
-rw-r--r--accessibility/eflite/pkg-descr14
-rw-r--r--accessibility/eflite/pkg-plist3
6 files changed, 90 insertions, 0 deletions
diff --git a/accessibility/Makefile b/accessibility/Makefile
index af6030e5312b..94358490f817 100644
--- a/accessibility/Makefile
+++ b/accessibility/Makefile
@@ -10,6 +10,7 @@
SUBDIR += atk
SUBDIR += atk-reference
SUBDIR += dasher
+ SUBDIR += eflite
SUBDIR += gail
SUBDIR += gail-reference
SUBDIR += gnome-mag
diff --git a/accessibility/eflite/Makefile b/accessibility/eflite/Makefile
new file mode 100644
index 000000000000..b90d574edca9
--- /dev/null
+++ b/accessibility/eflite/Makefile
@@ -0,0 +1,62 @@
+# Ports collection makefile for: eflite
+# Date created: Thu Jul 21 2005
+# Whom: David K. Gerry
+#
+# $FreeBSD$
+#
+
+PORTNAME= eflite
+PORTVERSION= 0.4.1
+CATEGORIES= accessibility
+MASTER_SITES= SF
+
+MAINTAINER= David.K.Gerry@GMail.com
+COMMENT= Speech server for Festival Lite used by yasr and Emacspeak
+
+BUILD_DEPENDS= flite:${PORTSDIR}/audio/flite
+RUN_DEPENDS= flite:${PORTSDIR}/audio/flite
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+ALL_TARGET= eflite
+
+CONFIGURE_ARGS+= --with-audio=freebsd
+.if defined(FL_LANG)
+CONFIGURE_ARGS+= --with-lang=${FL_LANG}
+.endif
+.if defined(FL_LEX)
+CONFIGURE_ARGS+= --with-lex=${FL_LEX}
+.endif
+.if defined(FL_VOX)
+CONFIGURE_ARGS+= --with-vox=${FL_VOX}
+.else
+CONFIGURE_ARGS+= --with-vox=cmu_us_kal16
+.endif
+
+PLIST_FILES= bin/eflite
+PORTDOCS= AUTHORS CREDITS ChangeLog INSTALL README
+
+pre-fetch:
+.ifdef!(FL_LANG || FL_LEX || FL_VOX)
+ @${ECHO_MSG} "===> You can set FL_LANG, FL_LEX and/or FL_VOX"
+ @${ECHO_MSG} " to link the appropriate libflite_* libraries"
+ @${ECHO_MSG} " (i.e. \"make FL_VOX=cmu_us_kal\".)"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/es\.conf|${PREFIX}/etc/es.conf|' ${WRKSRC}/es.c
+ @${REINPLACE_CMD} -e 's|/etc/es\.conf|${PREFIX}/etc/es.conf|;s|sockname|socketfile|g' ${WRKSRC}/INSTALL
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ ${INSTALL_DATA} ${FILESDIR}/es.conf.sample ${PREFIX}/etc
+ @if [ ! -f ${PREFIX}/etc/es.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/es.conf.sample ${PREFIX}/etc/es.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/accessibility/eflite/distinfo b/accessibility/eflite/distinfo
new file mode 100644
index 000000000000..bb993cfb1851
--- /dev/null
+++ b/accessibility/eflite/distinfo
@@ -0,0 +1,3 @@
+MD5 (eflite-0.4.1.tar.gz) = 9c1a25990426ae1c6519ee1a4528dc03
+SHA256 (eflite-0.4.1.tar.gz) = 91ad85855e55a3fc3b97a1a525db5fd1d211d54342bbfc88d1026813104f1721
+SIZE (eflite-0.4.1.tar.gz) = 63192
diff --git a/accessibility/eflite/files/es.conf.sample b/accessibility/eflite/files/es.conf.sample
new file mode 100644
index 000000000000..13e1162691be
--- /dev/null
+++ b/accessibility/eflite/files/es.conf.sample
@@ -0,0 +1,7 @@
+socketfile=/tmp/es.socket
+punct_some=@#$%^&_[]{}\|
+punct_all=!@#$%^&*()-=_+[]\|{};':",./<>?
+speech_volume=1000
+tone_volume=8192
+speaker_tones=1
+soundcard_tones=1
diff --git a/accessibility/eflite/pkg-descr b/accessibility/eflite/pkg-descr
new file mode 100644
index 000000000000..866870010c1c
--- /dev/null
+++ b/accessibility/eflite/pkg-descr
@@ -0,0 +1,14 @@
+EFlite is a speech server for Emacspeak and other screen readers that allows
+them to interface with Festival Lite, a free text-to-speech engine developed at
+the CMU Speech Center as an off-shoot of Festival. EFlite is still in beta,
+but I have been using it successfully with Yasr to get speech on my notebook
+under Linux without having to lug my Speak-out around. It uses Festival Lite's
+code to interface with the sound driver and, therefore, should work with some
+versions of ALSA, but I have only tested it with the OSS sound drivers so far.
+Michael P. Gorse
+mgorse@alum.wpi.edu
+mgorse@users.sf.net
+
+WWW: http://eflite.sourceforge.net/
+
+Ported by David K. Gerry <David.K.Gerry@GMail.com>
diff --git a/accessibility/eflite/pkg-plist b/accessibility/eflite/pkg-plist
new file mode 100644
index 000000000000..72343d84f22a
--- /dev/null
+++ b/accessibility/eflite/pkg-plist
@@ -0,0 +1,3 @@
+@unexec if cmp -s %D/etc/es.conf.sample %D/etc/es.conf; then rm -f %D/etc/es.conf; fi
+etc/es.conf.sample
+@exec if [ ! -f %D/etc/es.conf ]; then cp -p %D/%F %B/es.conf; fi