aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-21 20:20:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-21 20:20:32 +0000
commite60947bbeda112cb46d7dd0051ed3e5b0a6788cc (patch)
treeaf3c251cfa164878b04e75f11e5b4964df3d48a1 /accessibility
parente1d60dbb89d58406da5c6086d17da5d93956486f (diff)
downloadports-e60947bbeda112cb46d7dd0051ed3e5b0a6788cc.tar.gz
ports-e60947bbeda112cb46d7dd0051ed3e5b0a6788cc.zip
Notes
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/Makefile1
-rw-r--r--accessibility/py-papi/Makefile29
-rw-r--r--accessibility/py-papi/distinfo3
-rw-r--r--accessibility/py-papi/pkg-descr9
-rw-r--r--accessibility/py-papi/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/accessibility/Makefile b/accessibility/Makefile
index 130ce8d3a563..93ab624de314 100644
--- a/accessibility/Makefile
+++ b/accessibility/Makefile
@@ -18,6 +18,7 @@
SUBDIR += kdeaccessibility
SUBDIR += linux-atk
SUBDIR += orca
+ SUBDIR += py-papi
SUBDIR += ruby-atk
.include <bsd.port.subdir.mk>
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
new file mode 100644
index 000000000000..fb6f46cd2fb1
--- /dev/null
+++ b/accessibility/py-papi/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-papi
+# Date created: 2006-12-19
+# Whom: Marcus von Appen
+#
+# $FreeBSD$
+#
+
+PORTNAME= papi
+PORTVERSION= 0.0.2
+CATEGORIES= accessibility devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ocemp
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= papi-${PORTVERSION}
+
+MAINTAINER= mva@sysfault.org
+COMMENT= ATK accessibility wrapper for python
+
+USE_GNOME= atk
+USE_GCC= 3.4+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+post-patch:
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -i "" -e 's|: docfiles|: []|g' ${WRKSRC}/setup.py
+.endif
+
+.include <bsd.port.mk>
diff --git a/accessibility/py-papi/distinfo b/accessibility/py-papi/distinfo
new file mode 100644
index 000000000000..f74ca825f5c8
--- /dev/null
+++ b/accessibility/py-papi/distinfo
@@ -0,0 +1,3 @@
+MD5 (papi-0.0.2.tar.gz) = 194e090eb3fe177b397a59db03e9114b
+SHA256 (papi-0.0.2.tar.gz) = 8876ea2748e978296b4a07d1faeeb9230a9b7ffee57f3984c501a11414e08375
+SIZE (papi-0.0.2.tar.gz) = 52558
diff --git a/accessibility/py-papi/pkg-descr b/accessibility/py-papi/pkg-descr
new file mode 100644
index 000000000000..8612eb865275
--- /dev/null
+++ b/accessibility/py-papi/pkg-descr
@@ -0,0 +1,9 @@
+Papi, the Python Accessibility Programming Interface, is a Python
+wrapper around the GNOME ATK toolkit.
+It allows a developer to make python objects and applications
+easily accessibility aware without the need to install PyGTK and
+the GNOME accessibility components. Instead it only depends on ATK
+and - on the developers behalf - the ATK/AT-SPI bridge shipped with
+AT-SPI.
+
+WWW: http://ocemp.sourceforge.net/papi.html
diff --git a/accessibility/py-papi/pkg-plist b/accessibility/py-papi/pkg-plist
new file mode 100644
index 000000000000..8150d1c405ff
--- /dev/null
+++ b/accessibility/py-papi/pkg-plist
@@ -0,0 +1,6 @@
+%%PYTHON_SITELIBDIR%%/papi.so
+%%PORTDOCS%%%%DOCSDIR%%/examples/atkaction.py
+%%PORTDOCS%%%%DOCSDIR%%/examples/atkapplication.py
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%