aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-04-09 17:32:52 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-04-09 17:32:52 +0000
commit44106f83c5aca24b250fffedd5f3448b3f8daa82 (patch)
tree43f4e118b5b8b92e604227f862fa72608bf12290 /accessibility
parent0caefd3bc6fab7807a750f09c507789b07022bd3 (diff)
downloadports-44106f83c5aca24b250fffedd5f3448b3f8daa82.tar.gz
ports-44106f83c5aca24b250fffedd5f3448b3f8daa82.zip
Notes
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/gnome-speech/Makefile19
-rw-r--r--accessibility/gnome-speech/pkg-plist2
2 files changed, 20 insertions, 1 deletions
diff --git a/accessibility/gnome-speech/Makefile b/accessibility/gnome-speech/Makefile
index a1be6176cec4..55a153cf9213 100644
--- a/accessibility/gnome-speech/Makefile
+++ b/accessibility/gnome-speech/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnome-speech
PORTVERSION= 0.4.10
+PORTREVISION= 1
CATEGORIES= accessibility audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -27,12 +28,28 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libespeak.so)
+WITH_ESPEAK= yes
+.endif
+
.if exists(${LOCALBASE}/bin/festival)
WITH_FESTIVAL= yes
.endif
+.if defined(WITH_ESPEAK)
+LIB_DEPENDS+= espeak.1:${PORTSDIR}/audio/espeak
+CONFIGURE_ARGS+=--with-espeak-dir=${LOCALBASE}
+PLIST_SUB+= ESPEAK:=""
+.else
+PLIST_SUB+= ESPEAK:="@comment "
+.endif
+
.if defined(WITH_FESTIVAL)
-RUN_DEPENDS= festival:${PORTSDIR}/audio/festival
+RUN_DEPENDS+= festival:${PORTSDIR}/audio/festival
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|== x|= x|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/accessibility/gnome-speech/pkg-plist b/accessibility/gnome-speech/pkg-plist
index dc90aef8937f..33c2af07e02e 100644
--- a/accessibility/gnome-speech/pkg-plist
+++ b/accessibility/gnome-speech/pkg-plist
@@ -1,3 +1,4 @@
+%%ESPEAK:%%bin/espeak-synthesis-driver
bin/festival-synthesis-driver
bin/test-speech
include/gnome-speech-1.0/gnome-speech/GNOME_Speech.h
@@ -10,6 +11,7 @@ lib/libgnomespeech.so.7
lib/orbit-2.0/GNOME_Speech_module.a
lib/orbit-2.0/GNOME_Speech_module.la
lib/orbit-2.0/GNOME_Speech_module.so
+%%ESPEAK:%%libdata/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
libdata/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
libdata/pkgconfig/gnome-speech-1.0.pc
share/idl/gnome-speech-1.0/GNOME_Speech.idl