aboutsummaryrefslogtreecommitdiff
path: root/arabic/kacst_fonts/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-03-20 19:10:18 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-03-20 19:10:18 +0000
commitf7808e14a6d6cd305ff8ae166c9d7d171c515b54 (patch)
tree718a9be62cfb3f523502591162bc59c5d7d5c69a /arabic/kacst_fonts/Makefile
parent9e2f82105731a359d8ac611a8c9c283cbff53c50 (diff)
downloadports-f7808e14a6d6cd305ff8ae166c9d7d171c515b54.tar.gz
ports-f7808e14a6d6cd305ff8ae166c9d7d171c515b54.zip
Notes
Diffstat (limited to 'arabic/kacst_fonts/Makefile')
-rw-r--r--arabic/kacst_fonts/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/arabic/kacst_fonts/Makefile b/arabic/kacst_fonts/Makefile
index 5bee0cac796a..abeeb05aecfb 100644
--- a/arabic/kacst_fonts/Makefile
+++ b/arabic/kacst_fonts/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kacst_fonts
PORTVERSION= 2.01
+PORTREVISION= 1
CATEGORIES= arabic
MASTER_SITES= SF/arabeyes/${PORTNAME} \
http://www.c-s.li/ports/
@@ -13,20 +14,14 @@ COMMENT= Truetype Arabic fonts created by KACST
LICENSE= GPLv2
-BUILD_DEPENDS= ttmkfdir:${PORTSDIR}/x11-fonts/ttmkfdir
-
-USES= tar:bzip2
+USES= fonts tar:bzip2
WRKSRC= ${WRKDIR}/KacstArabicFonts-${PORTVERSION}
+NO_BUILD= yes
SUB_FILES= pkg-message
-SUB_LIST= PORTNAME="${PORTNAME}"
-
-do-build:
- (cd ${WRKDIR} && ttmkfdir -c -d ${WRKSRC} > ${WRKSRC}/fonts.dir)
do-install:
- @${MKDIR} ${STAGEDIR}/${PREFIX}/lib/X11/fonts/kacst_fonts
- ${INSTALL_DATA} ${WRKSRC}/*.ttf ${WRKSRC}/fonts.dir \
- ${STAGEDIR}/${PREFIX}/lib/X11/fonts/kacst_fonts
+ @${MKDIR} ${STAGEDIR}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}/${FONTSDIR}
.include <bsd.port.mk>