aboutsummaryrefslogtreecommitdiff
path: root/archivers/bzip
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-06-11 09:49:14 +0000
committerJohn Marino <marino@FreeBSD.org>2014-06-11 09:49:14 +0000
commite576cffda40aa643668e5d9064b774c7c66bbda7 (patch)
tree4bc94f3c6ac7c12f7f4042490796c245f9f4c84d /archivers/bzip
parent8efd504cb3706f75974e7e0413bf19e4549e9bc5 (diff)
downloadports-e576cffda40aa643668e5d9064b774c7c66bbda7.tar.gz
ports-e576cffda40aa643668e5d9064b774c7c66bbda7.zip
Notes
Diffstat (limited to 'archivers/bzip')
-rw-r--r--archivers/bzip/Makefile33
-rw-r--r--archivers/bzip/distinfo2
-rw-r--r--archivers/bzip/files/COPYRIGHT21
-rw-r--r--archivers/bzip/files/patch-Makefile43
-rw-r--r--archivers/bzip/files/patch-bzip.c59
-rw-r--r--archivers/bzip/pkg-descr15
6 files changed, 173 insertions, 0 deletions
diff --git a/archivers/bzip/Makefile b/archivers/bzip/Makefile
new file mode 100644
index 000000000000..94ab0aabcf4b
--- /dev/null
+++ b/archivers/bzip/Makefile
@@ -0,0 +1,33 @@
+# Created by: Andreas Klemm <andreas@klemm.gtn.com>
+# $FreeBSD$
+
+PORTNAME= bzip
+PORTVERSION= 0.21
+PORTREVISION= 1
+CATEGORIES= archivers
+MASTER_SITES= http://bsdforge.com/projects/source/archivers/bzip/
+
+MAINTAINER= portmaster@bsdforge.com
+COMMENT= Block-sorting file compressor
+
+LICENSE= GPLv2
+
+RESTRICTED= may be covered by patents
+USE_CSTD= gnu89
+
+PLIST_FILES= bin/bzip bin/bunzip \
+ man/man1/bunzip.1.gz \
+ man/man1/bzip.1.gz
+
+pre-install:
+ @${CAT} ${FILESDIR}/COPYRIGHT
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bzip ${STAGEDIR}${PREFIX}/bin
+ ${LN} -fs bzip ${STAGEDIR}${PREFIX}/bin/bunzip
+ ${INSTALL_MAN} ${WRKSRC}/bzip.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/bzip.1
+ ${INSTALL_MAN} ${WRKSRC}/bzip.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/bunzip.1
+
+.include <bsd.port.mk>
diff --git a/archivers/bzip/distinfo b/archivers/bzip/distinfo
new file mode 100644
index 000000000000..c49f8f5c2879
--- /dev/null
+++ b/archivers/bzip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bzip-0.21.tar.gz) = 85846f55406fa019305cee6f0aa3637769e857d8fff00eba26d8effc4539b014
+SIZE (bzip-0.21.tar.gz) = 325757
diff --git a/archivers/bzip/files/COPYRIGHT b/archivers/bzip/files/COPYRIGHT
new file mode 100644
index 000000000000..5f20d917c094
--- /dev/null
+++ b/archivers/bzip/files/COPYRIGHT
@@ -0,0 +1,21 @@
+COPYRIGHT
+=========
+
+BZIP is distributed under the GNU General Public License version
+2; for details, see the file LICENSE. Pointers to the algorithms
+used are in ALGORITHMS.
+
+COMMERCIAL USE
+==============
+
+This program may or may not infringe certain US patents pertaining
+to arithmetic coding and to the block-sorting transformation itself.
+Opinions differ as to the precise legal status of some of the
+algorithms used. Nevertheless, you should be aware that commercial
+use of this program could render you liable to unfriendly legal
+action.
+
+ Julian Seward <sewardj@cs.man.ac.uk>
+ Manchester, UK
+ 18 July 1996 (version 0.15)
+ 25 August 1996 (version 0.21)
diff --git a/archivers/bzip/files/patch-Makefile b/archivers/bzip/files/patch-Makefile
new file mode 100644
index 000000000000..69b52ae7048c
--- /dev/null
+++ b/archivers/bzip/files/patch-Makefile
@@ -0,0 +1,43 @@
+--- Makefile.orig Sat Aug 31 09:50:33 1996
++++ Makefile Fri Sep 27 13:57:55 1996
+@@ -1,29 +1,17 @@
+-
+-CC = gcc
+-SH = /bin/sh
+-
+-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -Wall -Winline -Wshadow -W
+-
+-
++CFLAGS+= -fomit-frame-pointer
+
+ all:
+- cat words0
+ $(CC) $(CFLAGS) -o bzip bzip.c
+- rm -f bunzip
+- ln -s ./bzip ./bunzip
+- cat words1
+- ./bzip -Q -1 < sample1.ref > sample1.rbz
+- ./bzip -Q -2 < sample2.ref > sample2.rbz
+- ./bunzip -Q < sample1.bz > sample1.tst
+- ./bunzip -Q < sample2.bz > sample2.tst
+- cat words2
+- cmp sample1.bz sample1.rbz
+- cmp sample2.bz sample2.rbz
+- cmp sample1.tst sample1.ref
+- cmp sample2.tst sample2.ref
+- cat words3
+-
++ @ln -fs ./bzip ./bunzip
++ @echo "*** testing bzip and bunzip ***"
++ ./bzip -Q -1 < sample1.ref > sample1.rbz || exit 1
++ ./bzip -Q -2 < sample2.ref > sample2.rbz || exit 1
++ ./bunzip -Q < sample1.bz > sample1.tst || exit 1
++ ./bunzip -Q < sample2.bz > sample2.tst || exit 1
++ cmp sample1.bz sample1.rbz || exit 1
++ cmp sample2.bz sample2.rbz || exit 1
++ cmp sample1.tst sample1.ref || exit 1
++ cmp sample2.tst sample2.ref || exit 1
+
+ clean:
+ rm -f bzip bunzip sample*.tst sample*.rbz
+-
diff --git a/archivers/bzip/files/patch-bzip.c b/archivers/bzip/files/patch-bzip.c
new file mode 100644
index 000000000000..ea9513a90511
--- /dev/null
+++ b/archivers/bzip/files/patch-bzip.c
@@ -0,0 +1,59 @@
+--- bzip.c.orig 1996-08-30 20:35:28.000000000 +0000
++++ bzip.c
+@@ -114,9 +114,13 @@
+ --*/
+
+ #if BZ_UNIX_32
++ #include <sys/types.h>
+ #include <utime.h>
+ #include <unistd.h>
++#if !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__NetBSD__) \
++ && !defined(__DragonFly__) /* stdlib already included above */
+ #include <malloc.h>
++#endif
+ #include <sys/stat.h>
+ #include <sys/times.h>
+
+@@ -2578,7 +2582,7 @@ void bitStreamEOF ()
+
+
+ /*---------------------------------------------*/
+-void mySignalCatcher ( IntNative *n )
++void mySignalCatcher (int n __unused)
+ {
+ fprintf ( stderr,
+ "\n%s: Control-C (or similar) caught, quitting.\n",
+@@ -2588,7 +2592,7 @@ void mySignalCatcher ( IntNative *n )
+
+
+ /*---------------------------------------------*/
+-void mySIGSEGVorSIGBUScatcher ( IntNative *n )
++void mySIGSEGVorSIGBUScatcher (int n __unused)
+ {
+ if (compressing)
+ fprintf ( stderr,
+@@ -3130,11 +3134,6 @@ IntNative main ( IntNative argc, Char *a
+ signal (SIGBUS, mySIGSEGVorSIGBUScatcher);
+ #endif
+
+- if ( ! (argc > 1 && strcmp ( "-Q", argv[1] ) == 0) )
+- fprintf ( stderr,
+- "BZIP, a block-sorting file compressor. "
+- "Version 0.21, 25-August-96.\n" );
+-
+ #if DEBUG
+ if ( ! (argc > 1 && strcmp ( "-Q", argv[1] ) == 0) )
+ fprintf ( stderr, "BZIP: *** compiled with debugging ON ***\n" );
+@@ -3205,6 +3204,12 @@ IntNative main ( IntNative argc, Char *a
+ break;
+ }
+
++ if (verbose) {
++ fprintf ( stderr,
++ "BZIP, a block-sorting file compressor. "
++ "Version 0.21, 25-August-96.\n" );
++ }
++
+ if ( opMode == OM_FILE_TO_STDOUT && numFileNames != 1) {
+ fprintf ( stderr, "%s: Option -c requires you to supply exactly one filename.\n",
+ progName );
diff --git a/archivers/bzip/pkg-descr b/archivers/bzip/pkg-descr
new file mode 100644
index 000000000000..2c2b02eb74e5
--- /dev/null
+++ b/archivers/bzip/pkg-descr
@@ -0,0 +1,15 @@
+Use of bzip2, which is intended to replace bzip, is recommended.
+The algorithms used in bzip2 are different and incompatible with
+those used in bzip. To open .bz archives, you must use bzip, and
+to open .bz2 archives you must use bzip2. Although bzip2 sometimes
+yields slightly larger output, it is faster, more reliable, maintained,
+much more widely used and is believed to be patent-free.
+
+Julian Seward, the author of bzip, gives this warning:
+
+ This program may or may not infringe certain US patents
+ pertaining to arithmetic coding and to the block-sorting
+ transformation itself. Opinions differ as to the precise
+ legal status of some of the algorithms used. Nevertheless,
+ you should be aware that commercial use of this program
+ could render you liable to unfriendly legal action.