aboutsummaryrefslogtreecommitdiff
path: root/archivers/cabextract
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-01-02 21:12:04 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-01-02 21:12:04 +0000
commitd420ebcb28041d8442c8b75a0f2da4c67ce869ad (patch)
treeac230c846d18f0dbdf7a83f35810ef6f6dbf17ee /archivers/cabextract
parent23c45dd6e7176155337802113def739b9a7c6294 (diff)
downloadports-d420ebcb28041d8442c8b75a0f2da4c67ce869ad.tar.gz
ports-d420ebcb28041d8442c8b75a0f2da4c67ce869ad.zip
Notes
Diffstat (limited to 'archivers/cabextract')
-rw-r--r--archivers/cabextract/Makefile24
-rw-r--r--archivers/cabextract/distinfo6
-rw-r--r--archivers/cabextract/files/patch-configure120
3 files changed, 17 insertions, 133 deletions
diff --git a/archivers/cabextract/Makefile b/archivers/cabextract/Makefile
index bb244ddbee9a..b062d79313ea 100644
--- a/archivers/cabextract/Makefile
+++ b/archivers/cabextract/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cabextract
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= archivers
MASTER_SITES= http://www.kyz.uklinux.net/downloads/
@@ -19,20 +18,25 @@ GNU_CONFIGURE= yes
MANLANG= "" ja
MAN1= cabextract.1
-PORTDOCS= magic wince_cab_format.html wince_info wince_rename \
- AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
PLIST_FILES= bin/cabextract
+DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+DOC_DOCS= magic wince_cab_format.html
+SRC_DOCS= wince_info wince_rename
+PORTDOCS= ${DOCS} ${DOC_DOCS} ${SRC_DOCS}
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/ja/cabextract.1 ${MAN1PREFIX}/man/ja/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/magic ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/wince_cab_format.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/src/wince_info ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/src/wince_rename ${DOCSDIR}
-.for i in AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.for i in ${DOC_DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.for i in ${SRC_DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/src/${i} ${DOCSDIR}
.endfor
.endif
diff --git a/archivers/cabextract/distinfo b/archivers/cabextract/distinfo
index 9977239c240e..dd4fbd6cf1bf 100644
--- a/archivers/cabextract/distinfo
+++ b/archivers/cabextract/distinfo
@@ -1,3 +1,3 @@
-MD5 (cabextract-1.1.tar.gz) = f4b729c0be7d288660f4fc167de199a1
-SHA256 (cabextract-1.1.tar.gz) = 32cdac1e2099eb7be1c49c267af4f2dc92c3097d8fdbe3dd087cdbe3a2c0cc8e
-SIZE (cabextract-1.1.tar.gz) = 187495
+MD5 (cabextract-1.2.tar.gz) = dc421a690648b503265c82ade84e143e
+SHA256 (cabextract-1.2.tar.gz) = ae9c860a74fcea109887b4cf5de8fce575ac14737571520b14b84816f17125eb
+SIZE (cabextract-1.2.tar.gz) = 194006
diff --git a/archivers/cabextract/files/patch-configure b/archivers/cabextract/files/patch-configure
deleted file mode 100644
index b83d42091ef8..000000000000
--- a/archivers/cabextract/files/patch-configure
+++ /dev/null
@@ -1,120 +0,0 @@
---- configure.orig Mon Oct 18 17:10:34 2004
-+++ configure Mon Oct 18 22:42:46 2004
-@@ -6609,117 +6650,6 @@
-
-
-
--for ac_func in mempcpy
--do
--as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
--echo "$as_me:$LINENO: checking for $ac_func" >&5
--echo $ECHO_N "checking for $ac_func... $ECHO_C" >&6
--if eval "test \"\${$as_ac_var+set}\" = set"; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--/* Define $ac_func to an innocuous variant, in case <limits.h> declares $ac_func.
-- For example, HP-UX 11i <limits.h> declares gettimeofday. */
--#define $ac_func innocuous_$ac_func
--
--/* System header to define __stub macros and hopefully few prototypes,
-- which can conflict with char $ac_func (); below.
-- Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
-- <limits.h> exists even on freestanding compilers. */
--
--#ifdef __STDC__
--# include <limits.h>
--#else
--# include <assert.h>
--#endif
--
--#undef $ac_func
--
--/* Override any gcc2 internal prototype to avoid an error. */
--#ifdef __cplusplus
--extern "C"
--{
--#endif
--/* We use char because int might match the return type of a gcc2
-- builtin and then its argument prototype would still apply. */
--char $ac_func ();
--/* The GNU C library defines this for functions which it implements
-- to always fail with ENOSYS. Some functions are actually named
-- something starting with __ and the normal name is an alias. */
--#if defined (__stub_$ac_func) || defined (__stub___$ac_func)
--choke me
--#else
--char (*f) () = $ac_func;
--#endif
--#ifdef __cplusplus
--}
--#endif
--
--int
--main ()
--{
--return f != $ac_func;
-- ;
-- return 0;
--}
--_ACEOF
--rm -f conftest.$ac_objext conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-- (eval $ac_link) 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } &&
-- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
-- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-- (eval $ac_try) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; } &&
-- { ac_try='test -s conftest$ac_exeext'
-- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-- (eval $ac_try) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; }; then
-- eval "$as_ac_var=yes"
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--eval "$as_ac_var=no"
--fi
--rm -f conftest.err conftest.$ac_objext \
-- conftest$ac_exeext conftest.$ac_ext
--fi
--echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_var'}'`" >&5
--echo "${ECHO_T}`eval echo '${'$as_ac_var'}'`" >&6
--if test `eval echo '${'$as_ac_var'}'` = yes; then
-- cat >>confdefs.h <<_ACEOF
--#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
--_ACEOF
--
--else
-- case $LIBOBJS in
-- "$ac_func.$ac_objext" | \
-- *" $ac_func.$ac_objext" | \
-- "$ac_func.$ac_objext "* | \
-- *" $ac_func.$ac_objext "* ) ;;
-- *) LIBOBJS="$LIBOBJS $ac_func.$ac_objext" ;;
--esac
--
--fi
--done
--
--
--
- ac_config_files="$ac_config_files Makefile cabextract.spec"
-
- cat >confcache <<\_ACEOF