aboutsummaryrefslogtreecommitdiff
path: root/archivers/deco/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2008-05-06 06:21:26 +0000
committerKevin Lo <kevlo@FreeBSD.org>2008-05-06 06:21:26 +0000
commitb3009e29cfcabbea9770124b7ebae1623aadff45 (patch)
treeb518da9a49735fc377a2613f2bf3593585d8f98b /archivers/deco/Makefile
parent30d270a334580b367d64dd3d2db145a1d447af4e (diff)
downloadports-b3009e29cfcabbea9770124b7ebae1623aadff45.tar.gz
ports-b3009e29cfcabbea9770124b7ebae1623aadff45.zip
Notes
Diffstat (limited to 'archivers/deco/Makefile')
-rw-r--r--archivers/deco/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/archivers/deco/Makefile b/archivers/deco/Makefile
new file mode 100644
index 000000000000..42be64aedf7b
--- /dev/null
+++ b/archivers/deco/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: deco
+# Date created: 06 May 2008
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deco
+PORTVERSION= 0.8.1
+CATEGORIES= archivers
+MASTER_SITES= http://hartlich.com/deco/download/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A script to extract various archive file formats
+
+RUN_DEPENDS= arc:${PORTSDIR}/archivers/arc \
+ arj:${PORTSDIR}/archivers/arj \
+ cabextract:${PORTSDIR}/archivers/cabextract \
+ dpkg:${PORTSDIR}/archivers/dpkg \
+ lzma:${PORTSDIR}/archivers/lzmautils \
+ 7z:${PORTSDIR}/archivers/p7zip \
+ rpm:${PORTSDIR}/archivers/rpm \
+ unace:${PORTSDIR}/archivers/unace \
+ unrar:${PORTSDIR}/archivers/unrar \
+ unzip:${PORTSDIR}/archivers/unzip \
+ zoo:${PORTSDIR}/archivers/zoo \
+ flac:${PORTSDIR}/audio/flac
+
+NO_BUILD= yes
+USE_GMAKE= yes
+
+CONFLICTS= deco-[0-9]*
+
+.include <bsd.port.mk>