aboutsummaryrefslogtreecommitdiff
path: root/archivers/deco
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2010-11-25 03:25:05 +0000
committerKevin Lo <kevlo@FreeBSD.org>2010-11-25 03:25:05 +0000
commit98fa194a83186868773644a5c7661827a5e1ece4 (patch)
tree6d90f44e2ec1e4343e506de1b357893c45b59608 /archivers/deco
parent039d146b4a3b92c21948172a57bce2cc785214df (diff)
downloadports-98fa194a83186868773644a5c7661827a5e1ece4.tar.gz
ports-98fa194a83186868773644a5c7661827a5e1ece4.zip
Handle xz compressed files
Notes
Notes: svn path=/head/; revision=265124
Diffstat (limited to 'archivers/deco')
-rw-r--r--archivers/deco/Makefile4
-rw-r--r--archivers/deco/files/extract3
2 files changed, 7 insertions, 0 deletions
diff --git a/archivers/deco/Makefile b/archivers/deco/Makefile
index e237131047f6..7c78038fbc3b 100644
--- a/archivers/deco/Makefile
+++ b/archivers/deco/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deco
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://hartlich.com/deco/download/:site1 \
http://hartlich.com/deco/archive/download/:site2
@@ -33,6 +34,9 @@ RUN_DEPENDS= arc:${PORTSDIR}/archivers/arc \
NO_LATEST_LINK= yes
CONFLICTS= deco-[0-9]*
+post-patch:
+ @${CP} ${FILESDIR}/extract ${WRKDIR}/${PORTNAME}-archive-1.5.1/"tar\.xz"
+
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
diff --git a/archivers/deco/files/extract b/archivers/deco/files/extract
new file mode 100644
index 000000000000..9674892164c9
--- /dev/null
+++ b/archivers/deco/files/extract
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec tar xJ${Verbose+vv}f "$1"