aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-05-18 21:52:55 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-05-18 21:52:55 +0000
commit15a2396d5047b6e8be9934e20bdf5168e598ed2d (patch)
tree901556c11c857d6976f3aeef9a8c7c81158aeae8 /archivers/file-roller/Makefile
parent4f87b1161ce48f6daed9a06970e4df8e47ba9035 (diff)
downloadports-15a2396d5047b6e8be9934e20bdf5168e598ed2d.tar.gz
ports-15a2396d5047b6e8be9934e20bdf5168e598ed2d.zip
Notes
Diffstat (limited to 'archivers/file-roller/Makefile')
-rw-r--r--archivers/file-roller/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
new file mode 100644
index 000000000000..1004403d9dc5
--- /dev/null
+++ b/archivers/file-roller/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fileroller
+# Date created: 18 May 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fileroller
+PORTVERSION= 1.0.1
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= file-roller-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip \
+ lha:${PORTSDIR}/archivers/lha \
+ rar:${PORTSDIR}/archivers/rar \
+ lzop:${PORTSDIR}/archivers/lzop
+
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+
+DOCS= AUTHORS COPYING NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>