aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /archivers/file-roller
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
Notes
Diffstat (limited to 'archivers/file-roller')
-rw-r--r--archivers/file-roller/Makefile9
-rw-r--r--archivers/file-roller/distinfo4
-rw-r--r--archivers/file-roller/files/patch-configure10
-rw-r--r--archivers/file-roller/files/patch-src_fr-command-tar.c52
-rw-r--r--archivers/file-roller/pkg-descr17
-rw-r--r--archivers/file-roller/pkg-plist97
6 files changed, 145 insertions, 44 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 0ef1b8968f96..d310eb698c7b 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= fileroller
-PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTVERSION= 2.6.0
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/file-roller/2.4
+MASTER_SITE_SUBDIR= sources/file-roller/2.6
DISTNAME= file-roller-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,8 +20,8 @@ COMMENT= An archive manager for zip files, tar, etc
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui lthack
-USE_LIBTOOL_VER= 13
+USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/archivers/file-roller/distinfo b/archivers/file-roller/distinfo
index e3f288dadb4d..992e44cd0fb8 100644
--- a/archivers/file-roller/distinfo
+++ b/archivers/file-roller/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/file-roller-2.4.4.tar.bz2) = 47bc36dce2d64b2bc5eb058492562605
-SIZE (gnome2/file-roller-2.4.4.tar.bz2) = 947224
+MD5 (gnome2/file-roller-2.6.0.tar.bz2) = 8c858a7cc4ab0f2844fd2148a2cfd954
+SIZE (gnome2/file-roller-2.6.0.tar.bz2) = 1241766
diff --git a/archivers/file-roller/files/patch-configure b/archivers/file-roller/files/patch-configure
new file mode 100644
index 000000000000..53e3c887712a
--- /dev/null
+++ b/archivers/file-roller/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue Dec 10 23:18:40 2002
++++ configure Tue Dec 10 23:18:59 2002
+@@ -6403,6 +6403,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/archivers/file-roller/files/patch-src_fr-command-tar.c b/archivers/file-roller/files/patch-src_fr-command-tar.c
index 9a0fb58a82ed..728ff0bce91f 100644
--- a/archivers/file-roller/files/patch-src_fr-command-tar.c
+++ b/archivers/file-roller/files/patch-src_fr-command-tar.c
@@ -1,35 +1,47 @@
---- src/fr-command-tar.c.orig Mon May 19 14:15:50 2003
-+++ src/fr-command-tar.c Tue May 20 20:43:39 2003
-@@ -83,6 +83,11 @@
- return mktime (&tm);
+--- src/fr-command-tar.c.orig Mon Mar 8 18:20:07 2004
++++ src/fr-command-tar.c Sun Mar 14 00:14:41 2004
+@@ -196,6 +196,11 @@
+ return g_strndup (f_start + 1, f_end - f_start);
}
+static char *months[] = {
-+ "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct",
-+ "Nov", "Dec"
++ "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct",
++ "Nov", "Dec"
+};
+
static void
process_line (char *line,
-@@ -92,19 +97,34 @@
+@@ -204,28 +209,36 @@
+ FileData *fdata;
FRCommand *comm = FR_COMMAND (data);
char **fields;
- const char *name_field;
+- int date_idx;
+- char *field_date, *field_time, *field_size, *field_name;
+ int i;
+ struct tm tm = {0, };
+ char **time_fields;
++ const char *field_name;
g_return_if_fail (line != NULL);
fdata = file_data_new ();
-- fields = split_line (line, 5);
+- date_idx = get_index_from_pattern (line, "%n%n%n%n-%n%n-%n%n %n%n:%n%n");
+ fields = split_line (line, 7);
- fdata->size = atol (fields[2]);
-- fdata->modified = mktime_from_string (fields[3], fields[4]);
+
+- field_size = get_prev_field (line, date_idx, 1);
+- fdata->size = atol (field_size);
+- g_free (field_size);
+-
+- field_date = get_next_field (line, date_idx, 1);
+- field_time = get_next_field (line, date_idx, 2);
+- fdata->modified = mktime_from_string (field_date, field_time);
+- g_free (field_date);
+- g_free (field_time);
++ fdata->size = atol (fields[2]);
+ for (i = 0; i < 12; i++) {
-+ if (!strncmp(fields[3], months[i], 3)) break;
++ if (!strncmp(fields[3], months[i], 3)) break;
+ }
+ tm.tm_mon = i;
+ tm.tm_year = atoi (fields[6]) - 1900;
@@ -40,13 +52,21 @@
+ tm.tm_sec = 0;
+ tm.tm_isdst = -1;
+ fdata->modified = mktime(&tm);
- g_strfreev (fields);
++ g_strfreev (fields);
+ g_strfreev (time_fields);
/* Full path */
-- name_field = get_last_field (line, 6);
-+ name_field = get_last_field (line, 8);
- fields = g_strsplit (name_field, " -> ", 2);
+- field_name = get_next_field (line, date_idx, 3);
++ field_name = get_last_field (line, 8);
+ fields = g_strsplit (field_name, " -> ", 2);
if (fields[1] == NULL) {
+@@ -244,7 +257,6 @@
+ if (fields[1] != NULL)
+ fdata->link = g_strdup (fields[1]);
+ g_strfreev (fields);
+- g_free (field_name);
+
+ fdata->name = g_strdup (file_name_from_path (fdata->full_path));
+ fdata->path = remove_level_from_path (fdata->full_path);
diff --git a/archivers/file-roller/pkg-descr b/archivers/file-roller/pkg-descr
index 66b4bc9dd688..703a89829953 100644
--- a/archivers/file-roller/pkg-descr
+++ b/archivers/file-roller/pkg-descr
@@ -1,13 +1,10 @@
-File Roller is an archive manager for the GNOME environment. Archive manager
-means that you can create and modify archives, view the content of an archive,
-view a file contained in the archive, and extract files from the archive.
-
-File Roller is only a front-end (a graphical interface) to archiving programs
-like tar and zip. The supported file types are :
+File Roller is an archive manager for the GNOME environment. It is only a
+front-end (a graphical interface) to archiving programs like tar and zip.
+The supported file types are:
* Tar archives uncompressed (.tar) or compressed with gzip (.tar.gz , .tgz),
-bzip (.tar.bz , .tbz), bzip2 (.tar.bz2 , .tbz2), compress (.tar.Z , .taz),
-lzop (.tar.lzo , .tzo)
+ bzip (.tar.bz , .tbz), bzip2 (.tar.bz2 , .tbz2), compress (.tar.Z , .taz),
+ lzop (.tar.lzo , .tzo)
* Zip archives (.zip)
* Jar archives (.jar , .ear , .war)
* Lha archives (.lzh)
@@ -15,9 +12,9 @@ lzop (.tar.lzo , .tzo)
* Single files compressed with gzip, bzip, bzip2, compress, lzop
File Roller also has a document viewer based on bonobo that lets you view files
-of any type you have a viewer for.
+of any type for which you have a viewer.
-Former WinZip users may find this program useful. It serves the same purpose.
+Former WinZip users may find this program useful. It serves the same purpose.
WWW: http://fileroller.sourceforge.net/
diff --git a/archivers/file-roller/pkg-plist b/archivers/file-roller/pkg-plist
index 210961829dde..465b7b057509 100644
--- a/archivers/file-roller/pkg-plist
+++ b/archivers/file-roller/pkg-plist
@@ -1,48 +1,96 @@
bin/file-roller
etc/gconf/gconf.xml.defaults/apps/file-roller/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/file-roller/dialogs/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/file-roller/dialogs/batch-add/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/file-roller/dialogs/extract/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/file-roller/general/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/file-roller/listing/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/file-roller/ui/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/dialogs/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/dialogs/batch-add/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/dialogs/extract/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/general/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/listing/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/ui/%gconf.xml
etc/gconf/schemas/file-roller.schemas
lib/bonobo/libfile-roller-component.so
libdata/bonobo/servers/File_Roller_Component.server
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/doc/fileroller/AUTHORS
+share/doc/fileroller/NEWS
+share/doc/fileroller/README
+share/doc/fileroller/TODO
share/gnome/application-registry/file-roller.applications
share/gnome/applications/file-roller.desktop
share/gnome/file-roller/glade/file_roller.glade
share/gnome/file-roller/glade/file_roller_prop.glade
+share/gnome/help/file-roller/C/figures/file-roller_home.png
+share/gnome/help/file-roller/C/figures/file-roller_leftarrow.png
share/gnome/help/file-roller/C/figures/file-roller_main_window.png
+share/gnome/help/file-roller/C/figures/file-roller_rightarrow.png
+share/gnome/help/file-roller/C/figures/file-roller_uparrow.png
share/gnome/help/file-roller/C/file-roller.xml
share/gnome/help/file-roller/C/legal.xml
+share/gnome/help/file-roller/de/figures/file-roller_main_window.png
+share/gnome/help/file-roller/de/file-roller.xml
+share/gnome/help/file-roller/de/legal.xml
+share/gnome/help/file-roller/es/figures/file-roller_main_window.png
+share/gnome/help/file-roller/es/file-roller.xml
+share/gnome/help/file-roller/es/legal.xml
+share/gnome/help/file-roller/fr/figures/file-roller_main_window.png
+share/gnome/help/file-roller/fr/file-roller.xml
+share/gnome/help/file-roller/fr/legal.xml
+share/gnome/help/file-roller/it/figures/file-roller_main_window.png
+share/gnome/help/file-roller/it/file-roller.xml
+share/gnome/help/file-roller/it/legal.xml
+share/gnome/help/file-roller/ja/figures/file-roller_main_window.png
+share/gnome/help/file-roller/ja/file-roller.xml
+share/gnome/help/file-roller/ja/legal.xml
+share/gnome/help/file-roller/ko/figures/file-roller_main_window.png
+share/gnome/help/file-roller/ko/file-roller.xml
+share/gnome/help/file-roller/ko/legal.xml
share/gnome/help/file-roller/ru/figures/fr-add-dialog.png
share/gnome/help/file-roller/ru/figures/fr-extract.png
share/gnome/help/file-roller/ru/figures/fr-mainwindow.png
share/gnome/help/file-roller/ru/figures/fr-prefs.png
share/gnome/help/file-roller/ru/file-roller.xml
share/gnome/help/file-roller/ru/legal.xml
+share/gnome/help/file-roller/sv/figures/file-roller_main_window.png
+share/gnome/help/file-roller/sv/file-roller.xml
+share/gnome/help/file-roller/sv/legal.xml
share/gnome/help/file-roller/uk/figures/fr-add-dialog.png
share/gnome/help/file-roller/uk/figures/fr-extract.png
share/gnome/help/file-roller/uk/figures/fr-mainwindow.png
share/gnome/help/file-roller/uk/figures/fr-prefs.png
share/gnome/help/file-roller/uk/file-roller.xml
share/gnome/help/file-roller/uk/legal.xml
+share/gnome/help/file-roller/zh_CN/figures/file-roller_main_window.png
+share/gnome/help/file-roller/zh_CN/file-roller.xml
+share/gnome/help/file-roller/zh_CN/legal.xml
+share/gnome/help/file-roller/zh_HK/figures/file-roller_main_window.png
+share/gnome/help/file-roller/zh_HK/file-roller.xml
+share/gnome/help/file-roller/zh_HK/legal.xml
+share/gnome/help/file-roller/zh_TW/figures/file-roller_main_window.png
+share/gnome/help/file-roller/zh_TW/file-roller.xml
+share/gnome/help/file-roller/zh_TW/legal.xml
share/gnome/mime-info/file-roller.keys
share/gnome/mime-info/file-roller.mime
share/gnome/omf/file-roller/file-roller-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/file-roller/file-roller-C.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/file-roller/file-roller-de.omf
+share/gnome/omf/file-roller/file-roller-es.omf
+share/gnome/omf/file-roller/file-roller-fr.omf
+share/gnome/omf/file-roller/file-roller-it.omf
+share/gnome/omf/file-roller/file-roller-ja.omf
+share/gnome/omf/file-roller/file-roller-ko.omf
share/gnome/omf/file-roller/file-roller-ru.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/file-roller/file-roller-ru.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/file-roller/file-roller-sv.omf
share/gnome/omf/file-roller/file-roller-uk.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/file-roller/file-roller-uk.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/file-roller/file-roller-zh_CN.omf
+share/gnome/omf/file-roller/file-roller-zh_HK.omf
+share/gnome/omf/file-roller/file-roller-zh_TW.omf
share/gnome/pixmaps/file-roller.png
share/locale/am/LC_MESSAGES/file-roller.mo
+share/locale/ar/LC_MESSAGES/file-roller.mo
share/locale/az/LC_MESSAGES/file-roller.mo
share/locale/be/LC_MESSAGES/file-roller.mo
share/locale/bg/LC_MESSAGES/file-roller.mo
@@ -53,6 +101,7 @@ share/locale/cy/LC_MESSAGES/file-roller.mo
share/locale/da/LC_MESSAGES/file-roller.mo
share/locale/de/LC_MESSAGES/file-roller.mo
share/locale/el/LC_MESSAGES/file-roller.mo
+share/locale/en_GB/LC_MESSAGES/file-roller.mo
share/locale/es/LC_MESSAGES/file-roller.mo
share/locale/et/LC_MESSAGES/file-roller.mo
share/locale/eu/LC_MESSAGES/file-roller.mo
@@ -62,6 +111,7 @@ share/locale/fr/LC_MESSAGES/file-roller.mo
share/locale/ga/LC_MESSAGES/file-roller.mo
share/locale/he/LC_MESSAGES/file-roller.mo
share/locale/hi/LC_MESSAGES/file-roller.mo
+share/locale/hr/LC_MESSAGES/file-roller.mo
share/locale/hu/LC_MESSAGES/file-roller.mo
share/locale/id/LC_MESSAGES/file-roller.mo
share/locale/is/LC_MESSAGES/file-roller.mo
@@ -78,6 +128,7 @@ share/locale/ms/LC_MESSAGES/file-roller.mo
share/locale/nl/LC_MESSAGES/file-roller.mo
share/locale/nn/LC_MESSAGES/file-roller.mo
share/locale/no/LC_MESSAGES/file-roller.mo
+share/locale/pa/LC_MESSAGES/file-roller.mo
share/locale/pl/LC_MESSAGES/file-roller.mo
share/locale/pt/LC_MESSAGES/file-roller.mo
share/locale/pt_BR/LC_MESSAGES/file-roller.mo
@@ -88,6 +139,7 @@ share/locale/sl/LC_MESSAGES/file-roller.mo
share/locale/sq/LC_MESSAGES/file-roller.mo
share/locale/sr/LC_MESSAGES/file-roller.mo
share/locale/sr@Latn/LC_MESSAGES/file-roller.mo
+share/locale/sr@ije/LC_MESSAGES/file-roller.mo
share/locale/sv/LC_MESSAGES/file-roller.mo
share/locale/ta/LC_MESSAGES/file-roller.mo
share/locale/th/LC_MESSAGES/file-roller.mo
@@ -97,24 +149,47 @@ share/locale/vi/LC_MESSAGES/file-roller.mo
share/locale/zh_CN/LC_MESSAGES/file-roller.mo
share/locale/zh_TW/LC_MESSAGES/file-roller.mo
@dirrm share/gnome/omf/file-roller
+@dirrm share/gnome/help/file-roller/zh_TW/figures
+@dirrm share/gnome/help/file-roller/zh_TW
+@dirrm share/gnome/help/file-roller/zh_HK/figures
+@dirrm share/gnome/help/file-roller/zh_HK
+@dirrm share/gnome/help/file-roller/zh_CN/figures
+@dirrm share/gnome/help/file-roller/zh_CN
@dirrm share/gnome/help/file-roller/uk/figures
@dirrm share/gnome/help/file-roller/uk
+@dirrm share/gnome/help/file-roller/sv/figures
+@dirrm share/gnome/help/file-roller/sv
@dirrm share/gnome/help/file-roller/ru/figures
@dirrm share/gnome/help/file-roller/ru
+@dirrm share/gnome/help/file-roller/ko/figures
+@dirrm share/gnome/help/file-roller/ko
+@dirrm share/gnome/help/file-roller/ja/figures
+@dirrm share/gnome/help/file-roller/ja
+@dirrm share/gnome/help/file-roller/it/figures
+@dirrm share/gnome/help/file-roller/it
+@dirrm share/gnome/help/file-roller/fr/figures
+@dirrm share/gnome/help/file-roller/fr
+@dirrm share/gnome/help/file-roller/es/figures
+@dirrm share/gnome/help/file-roller/es
+@dirrm share/gnome/help/file-roller/de/figures
+@dirrm share/gnome/help/file-roller/de
@dirrm share/gnome/help/file-roller/C/figures
@dirrm share/gnome/help/file-roller/C
@dirrm share/gnome/help/file-roller
@dirrm share/gnome/file-roller/glade
@dirrm share/gnome/file-roller
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/doc/fileroller
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/ui
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/listing
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/general
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/dialogs/extract
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/dialogs/batch-add
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller/dialogs
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/file-roller
@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller/ui
@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller/listing
@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller/general
+@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller/dialogs/extract
+@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller/dialogs/batch-add
+@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller/dialogs
@dirrm etc/gconf/gconf.xml.defaults/apps/file-roller
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/file-roller/file-roller-uk.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/file-roller/file-roller-ru.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/file-roller/file-roller-C.omf 2>/dev/null || /usr/bin/true