aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /archivers/file-roller
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'archivers/file-roller')
-rw-r--r--archivers/file-roller/Makefile6
-rw-r--r--archivers/file-roller/distinfo5
-rw-r--r--archivers/file-roller/files/patch-src_fr-command-lrzip.c11
-rw-r--r--archivers/file-roller/pkg-plist16
4 files changed, 33 insertions, 5 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 14b14d13fb2c..299c8ec781e4 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -3,11 +3,11 @@
# Whom: Anders Nordby <anders@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/archivers/file-roller/Makefile,v 1.5 2010/06/23 15:16:03 kwm Exp $
+# $MCom: ports/archivers/file-roller/Makefile,v 1.184 2010/11/15 22:58:48 kwm Exp $
#
PORTNAME= file-roller
-PORTVERSION= 2.30.2
+PORTVERSION= 2.32.1
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
@@ -29,10 +29,12 @@ INSTALLS_ICONS= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gnomehack desktopfileutils gnomedocutils \
gtk20 gconf2
+GNOME_DESKTOP_VERSION=2
USE_XORG= sm
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-packagekit
PORTDOCS= AUTHORS NEWS README TODO ChangeLog
GCONF_SCHEMAS= file-roller.schemas
diff --git a/archivers/file-roller/distinfo b/archivers/file-roller/distinfo
index 686e3829684f..0391b548bd16 100644
--- a/archivers/file-roller/distinfo
+++ b/archivers/file-roller/distinfo
@@ -1,3 +1,2 @@
-MD5 (gnome2/file-roller-2.30.2.tar.bz2) = c13209518d2e2294ec1fa813e063b0c5
-SHA256 (gnome2/file-roller-2.30.2.tar.bz2) = 34e809ee4e11d85d314b9060a5641a68e55046d429bf8a435a24b777eec8b2f5
-SIZE (gnome2/file-roller-2.30.2.tar.bz2) = 1818246
+SHA256 (gnome2/file-roller-2.32.1.tar.bz2) = a9109d9c871c022eb0553eeedc98520bad42ba3099088c16a9f7df817f60cc92
+SIZE (gnome2/file-roller-2.32.1.tar.bz2) = 1916180
diff --git a/archivers/file-roller/files/patch-src_fr-command-lrzip.c b/archivers/file-roller/files/patch-src_fr-command-lrzip.c
new file mode 100644
index 000000000000..ae2d7d440482
--- /dev/null
+++ b/archivers/file-roller/files/patch-src_fr-command-lrzip.c
@@ -0,0 +1,11 @@
+--- src/fr-command-lrzip.c.orig 2010-08-26 12:40:56.000000000 -0400
++++ src/fr-command-lrzip.c 2010-08-26 12:41:41.000000000 -0400
+@@ -53,7 +53,7 @@ list__process_line (char *line,
+ struct stat st;
+ time_t tt;
+ if (stat (comm->filename, &st) == 0)
+- fdata->modified = st.st_mtim.tv_sec;
++ fdata->modified = st.st_mtime;
+ else
+ time(&(fdata->modified));
+ fdata->modified;
diff --git a/archivers/file-roller/pkg-plist b/archivers/file-roller/pkg-plist
index b45025293667..6af23090ca35 100644
--- a/archivers/file-roller/pkg-plist
+++ b/archivers/file-roller/pkg-plist
@@ -87,6 +87,12 @@ share/gnome/help/file-roller/it/figures/file-roller_main_window.png
share/gnome/help/file-roller/it/figures/file-roller_rightarrow.png
share/gnome/help/file-roller/it/figures/file-roller_uparrow.png
share/gnome/help/file-roller/it/file-roller.xml
+share/gnome/help/file-roller/ja/figures/file-roller_home.png
+share/gnome/help/file-roller/ja/figures/file-roller_leftarrow.png
+share/gnome/help/file-roller/ja/figures/file-roller_main_window.png
+share/gnome/help/file-roller/ja/figures/file-roller_rightarrow.png
+share/gnome/help/file-roller/ja/figures/file-roller_uparrow.png
+share/gnome/help/file-roller/ja/file-roller.xml
share/gnome/help/file-roller/nl/figures/file-roller_home.png
share/gnome/help/file-roller/nl/figures/file-roller_leftarrow.png
share/gnome/help/file-roller/nl/figures/file-roller_main_window.png
@@ -158,6 +164,7 @@ share/locale/el/LC_MESSAGES/file-roller.mo
share/locale/en@shaw/LC_MESSAGES/file-roller.mo
share/locale/en_CA/LC_MESSAGES/file-roller.mo
share/locale/en_GB/LC_MESSAGES/file-roller.mo
+share/locale/eo/LC_MESSAGES/file-roller.mo
share/locale/es/LC_MESSAGES/file-roller.mo
share/locale/et/LC_MESSAGES/file-roller.mo
share/locale/eu/LC_MESSAGES/file-roller.mo
@@ -165,6 +172,7 @@ share/locale/fa/LC_MESSAGES/file-roller.mo
share/locale/fi/LC_MESSAGES/file-roller.mo
share/locale/fr/LC_MESSAGES/file-roller.mo
share/locale/fur/LC_MESSAGES/file-roller.mo
+share/locale/fy/LC_MESSAGES/file-roller.mo
share/locale/ga/LC_MESSAGES/file-roller.mo
share/locale/gl/LC_MESSAGES/file-roller.mo
share/locale/gu/LC_MESSAGES/file-roller.mo
@@ -219,6 +227,7 @@ share/locale/te/LC_MESSAGES/file-roller.mo
share/locale/th/LC_MESSAGES/file-roller.mo
share/locale/tk/LC_MESSAGES/file-roller.mo
share/locale/tr/LC_MESSAGES/file-roller.mo
+share/locale/ug/LC_MESSAGES/file-roller.mo
share/locale/uk/LC_MESSAGES/file-roller.mo
share/locale/ur/LC_MESSAGES/file-roller.mo
share/locale/ur_PK/LC_MESSAGES/file-roller.mo
@@ -238,6 +247,7 @@ share/omf/file-roller/file-roller-es.omf
share/omf/file-roller/file-roller-fi.omf
share/omf/file-roller/file-roller-fr.omf
share/omf/file-roller/file-roller-it.omf
+share/omf/file-roller/file-roller-ja.omf
share/omf/file-roller/file-roller-nl.omf
share/omf/file-roller/file-roller-oc.omf
share/omf/file-roller/file-roller-ru.omf
@@ -260,6 +270,8 @@ share/omf/file-roller/file-roller-zh_CN.omf
@dirrm share/gnome/help/file-roller/oc
@dirrm share/gnome/help/file-roller/nl/figures
@dirrm share/gnome/help/file-roller/nl
+@dirrm share/gnome/help/file-roller/ja/figures
+@dirrm share/gnome/help/file-roller/ja
@dirrm share/gnome/help/file-roller/it/figures
@dirrm share/gnome/help/file-roller/it
@dirrm share/gnome/help/file-roller/fr/figures
@@ -303,6 +315,8 @@ share/omf/file-roller/file-roller-zh_CN.omf
@dirrmtry share/locale/ur_PK
@dirrmtry share/locale/ur/LC_MESSAGES
@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@@ -331,6 +345,8 @@ share/omf/file-roller/file-roller-zh_CN.omf
@dirrmtry share/locale/kk
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/fy/LC_MESSAGES
+@dirrmtry share/locale/fy
@dirrmtry share/locale/fur/LC_MESSAGES
@dirrmtry share/locale/fur
@dirrmtry share/locale/en@shaw/LC_MESSAGES