aboutsummaryrefslogtreecommitdiff
path: root/archivers/fpc-paszlib
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-12 21:54:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-12 21:54:29 +0000
commit372451b6d2d52fafabc045c48caeb9eab9a2164c (patch)
tree9a0acad65d5563bcdf56ef3931f6a9da6c138cd9 /archivers/fpc-paszlib
parent2abaca8e663b463ab7129a292642d22d6cd8c82a (diff)
downloadports-372451b6d2d52fafabc045c48caeb9eab9a2164c.tar.gz
ports-372451b6d2d52fafabc045c48caeb9eab9a2164c.zip
Notes
Diffstat (limited to 'archivers/fpc-paszlib')
-rw-r--r--archivers/fpc-paszlib/Makefile47
-rw-r--r--archivers/fpc-paszlib/distinfo2
-rw-r--r--archivers/fpc-paszlib/pkg-descr8
-rw-r--r--archivers/fpc-paszlib/pkg-plist38
4 files changed, 95 insertions, 0 deletions
diff --git a/archivers/fpc-paszlib/Makefile b/archivers/fpc-paszlib/Makefile
new file mode 100644
index 000000000000..16bced0aa260
--- /dev/null
+++ b/archivers/fpc-paszlib/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: FreeVision
+# Date created: 9 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= paszlib
+PORTVERSION= 1.0.10
+CATEGORIES= archivers devel
+MASTER_SITES= http://www.borgsdemons.com/distfiles/
+PKGNAMEPREFIX= fpc-
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal unit for native compression IO
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= INSTDIR=lib/fpc/${PORTVERSION}/units/freebsd/paszlib \
+ PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKDIR}/paszlib -name "Makefile*" | ${XARGS} \
+ ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C ${WRKDIR}/paszlib all
+
+do-install:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C ${WRKDIR}/paszlib install
+
+.include <bsd.port.post.mk>
diff --git a/archivers/fpc-paszlib/distinfo b/archivers/fpc-paszlib/distinfo
new file mode 100644
index 000000000000..2a8cc29be49e
--- /dev/null
+++ b/archivers/fpc-paszlib/distinfo
@@ -0,0 +1,2 @@
+MD5 (paszlib-1.0.10.tar.gz) = 4d52f1d084a424a5deabc4f47eb4d370
+SIZE (paszlib-1.0.10.tar.gz) = 96724
diff --git a/archivers/fpc-paszlib/pkg-descr b/archivers/fpc-paszlib/pkg-descr
new file mode 100644
index 000000000000..4188f4bd9233
--- /dev/null
+++ b/archivers/fpc-paszlib/pkg-descr
@@ -0,0 +1,8 @@
+The paszlib unit is one of the base packages developed for
+Free Pascal, a 32-bit Turbo Pascal/Delphi compatible compiler.
+This unit provides some of the interfaces in Delphi Vision.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/archivers/fpc-paszlib/pkg-plist b/archivers/fpc-paszlib/pkg-plist
new file mode 100644
index 000000000000..61c1c2a14c59
--- /dev/null
+++ b/archivers/fpc-paszlib/pkg-plist
@@ -0,0 +1,38 @@
+%%INSTDIR%%/Package.fpc
+%%INSTDIR%%/adler.o
+%%INSTDIR%%/adler.ppu
+%%INSTDIR%%/gzcrc.o
+%%INSTDIR%%/gzcrc.ppu
+%%INSTDIR%%/gzio.o
+%%INSTDIR%%/gzio.ppu
+%%INSTDIR%%/infblock.o
+%%INSTDIR%%/infblock.ppu
+%%INSTDIR%%/infcodes.o
+%%INSTDIR%%/infcodes.ppu
+%%INSTDIR%%/inffast.o
+%%INSTDIR%%/inffast.ppu
+%%INSTDIR%%/inftrees.o
+%%INSTDIR%%/inftrees.ppu
+%%INSTDIR%%/infutil.o
+%%INSTDIR%%/infutil.ppu
+%%INSTDIR%%/paszlib.o
+%%INSTDIR%%/paszlib.ppu
+%%INSTDIR%%/trees.o
+%%INSTDIR%%/trees.ppu
+%%INSTDIR%%/zbase.o
+%%INSTDIR%%/zbase.ppu
+%%INSTDIR%%/zcompres.o
+%%INSTDIR%%/zcompres.ppu
+%%INSTDIR%%/zdeflate.o
+%%INSTDIR%%/zdeflate.ppu
+%%INSTDIR%%/zinflate.o
+%%INSTDIR%%/zinflate.ppu
+%%INSTDIR%%/zuncompr.o
+%%INSTDIR%%/zuncompr.ppu
+%%INSTDIR%%/zutil.o
+%%INSTDIR%%/zutil.ppu
+@dirrm %%INSTDIR%%
+@unexec rmdir %D/lib/fpc/%%PORTVERSION%%/units/freebsd 2>/dev/null || true
+@unexec rmdir %D/lib/fpc/%%PORTVERSION%%/units 2>/dev/null || true
+@unexec rmdir %D/lib/fpc/%%PORTVERSION%% 2>/dev/null || true
+@unexec rmdir %D/lib/fpc 2>/dev/null || true