aboutsummaryrefslogtreecommitdiff
path: root/archivers/gcpio
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2010-03-25 21:54:41 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2010-03-25 21:54:41 +0000
commit572049dc827a7f9850ba77afbe6cbb6caf0ccca3 (patch)
tree92e27d9951d1a9c9e18ad56df78eeb7cad6d4785 /archivers/gcpio
parent0bf43dd57d20be33b40fc1c50175020ce28cfa49 (diff)
downloadports-572049dc827a7f9850ba77afbe6cbb6caf0ccca3.tar.gz
ports-572049dc827a7f9850ba77afbe6cbb6caf0ccca3.zip
Notes
Diffstat (limited to 'archivers/gcpio')
-rw-r--r--archivers/gcpio/Makefile40
-rw-r--r--archivers/gcpio/distinfo3
-rw-r--r--archivers/gcpio/files/patch-doc_Makefile.in11
-rw-r--r--archivers/gcpio/files/patch-doc_cpio.132
-rw-r--r--archivers/gcpio/files/patch-gnu_Makefile.in11
-rw-r--r--archivers/gcpio/pkg-descr17
-rw-r--r--archivers/gcpio/pkg-plist23
7 files changed, 137 insertions, 0 deletions
diff --git a/archivers/gcpio/Makefile b/archivers/gcpio/Makefile
new file mode 100644
index 000000000000..282c828c76e1
--- /dev/null
+++ b/archivers/gcpio/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gcpio
+# Date created: 2010-03-25
+# Whom: Christian Weisgerber <naddy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpio
+PORTVERSION= 2.11
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= g
+
+MAINTAINER= naddy@FreeBSD.org
+COMMENT= GNU cpio copies files to and from archives
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+CONFIGURE_ARGS= --program-prefix=g \
+ --disable-silent-rules \
+ --with-rmt=/etc/rmt
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+INFO= cpio
+MAN1= gcpio.1
+
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/archivers/gcpio/distinfo b/archivers/gcpio/distinfo
new file mode 100644
index 000000000000..e7e5aff2fc7d
--- /dev/null
+++ b/archivers/gcpio/distinfo
@@ -0,0 +1,3 @@
+MD5 (cpio-2.11.tar.bz2) = 20fc912915c629e809f80b96b2e75d7d
+SHA256 (cpio-2.11.tar.bz2) = bb820bfd96e74fc6ce43104f06fe733178517e7f5d1cdee553773e8eff7d5bbd
+SIZE (cpio-2.11.tar.bz2) = 1018483
diff --git a/archivers/gcpio/files/patch-doc_Makefile.in b/archivers/gcpio/files/patch-doc_Makefile.in
new file mode 100644
index 000000000000..6bbce4ec409a
--- /dev/null
+++ b/archivers/gcpio/files/patch-doc_Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig 2010-03-25 22:34:54.000000000 +0100
++++ doc/Makefile.in 2010-03-25 22:35:08.000000000 +0100
+@@ -813,7 +813,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ info_TEXINFOS = cpio.texi
+-man_MANS = cpio.1 mt.1
++man_MANS = cpio.1
+ EXTRA_DIST = $(man_MANS) gendocs_template
+ all: all-am
+
diff --git a/archivers/gcpio/files/patch-doc_cpio.1 b/archivers/gcpio/files/patch-doc_cpio.1
new file mode 100644
index 000000000000..6c85b8d58319
--- /dev/null
+++ b/archivers/gcpio/files/patch-doc_cpio.1
@@ -0,0 +1,32 @@
+--- doc/cpio.1.orig 2009-02-14 19:15:50.000000000 +0100
++++ doc/cpio.1 2010-03-25 22:35:50.000000000 +0100
+@@ -1,8 +1,8 @@
+-.TH CPIO 1L \" -*- nroff -*-
++.TH GCPIO 1L \" -*- nroff -*-
+ .SH NAME
+-cpio \- copy files to and from archives
++gcpio \- copy files to and from archives
+ .SH SYNOPSIS
+-.B cpio
++.B gcpio
+ {\-o|\-\-create} [\-0acvABLV] [\-C bytes] [\-H format] [\-M message]
+ [\-O [[user@]host:]archive] [\-F [[user@]host:]archive]
+ [\-\-file=[[user@]host:]archive] [\-\-format=format] [\-\-message=message]
+@@ -11,7 +11,7 @@ cpio \- copy files to and from archives
+ [\-\-force\-local] [\-\-rsh-command=command] [\-\-help] [\-\-version]
+ < name-list [> archive]
+
+-.B cpio
++.B gcpio
+ {\-i|\-\-extract} [\-bcdfmnrtsuvBSV] [\-C bytes] [\-E file] [\-H format]
+ [\-M message] [\-R [user][:.][group]] [\-I [[user@]host:]archive]
+ [\-F [[user@]host:]archive] [\-\-file=[[user@]host:]archive]
+@@ -24,7 +24,7 @@ cpio \- copy files to and from archives
+ [\-\-only\-verify\-crc] [\-\-to\-stdout] [\-\-quiet] [\-\-rsh-command=command]
+ [\-\-help] [\-\-version] [pattern...] [< archive]
+
+-.B cpio
++.B gcpio
+ {\-p|\-\-pass-through} [\-0adlmuvLV] [\-R [user][:.][group]]
+ [\-\-null] [\-\-reset-access-time] [\-\-make-directories] [\-\-link] [\-\-quiet]
+ [\-\-preserve-modification-time] [\-\-unconditional] [\-\-verbose] [\-\-dot]
diff --git a/archivers/gcpio/files/patch-gnu_Makefile.in b/archivers/gcpio/files/patch-gnu_Makefile.in
new file mode 100644
index 000000000000..0d6b6ad3d446
--- /dev/null
+++ b/archivers/gcpio/files/patch-gnu_Makefile.in
@@ -0,0 +1,11 @@
+--- gnu/Makefile.in.orig 2010-03-25 22:13:33.000000000 +0100
++++ gnu/Makefile.in 2010-03-25 22:14:21.000000000 +0100
+@@ -1720,7 +1720,7 @@ inttypes.h: inttypes.in.h $(WARN_ON_USE_
+ # avoid installing it.
+
+ all-local: charset.alias ref-add.sed ref-del.sed
+-install-exec-local: install-exec-localcharset
++install-exec-local:
+ install-exec-localcharset: all-local
+ if test $(GLIBC21) = no; then \
+ case '$(host_os)' in \
diff --git a/archivers/gcpio/pkg-descr b/archivers/gcpio/pkg-descr
new file mode 100644
index 000000000000..62575ed173ff
--- /dev/null
+++ b/archivers/gcpio/pkg-descr
@@ -0,0 +1,17 @@
+GNU cpio copies files into or out of a cpio or tar archive. The
+archive can be another file on the disk, a magnetic tape, or a pipe.
+
+GNU cpio supports the following archive formats: binary, old ASCII,
+new ASCII, crc, HPUX binary, HPUX old ASCII, old tar, and POSIX.1
+tar. The tar format is provided for compatibility with the tar
+program. By default, cpio creates binary format archives, for
+compatibility with older cpio programs. When extracting from
+archives, cpio automatically recognizes which kind of archive it
+is reading and can read archives created on machines with a different
+byte-order.
+
+Note that this port will install these utilities with a 'g' prefix,
+e.g. gcpio, but the texinfo documentation will refer to them without
+the 'g' prefix.
+
+WWW: http://www.gnu.org/software/cpio/
diff --git a/archivers/gcpio/pkg-plist b/archivers/gcpio/pkg-plist
new file mode 100644
index 000000000000..17d4953e643d
--- /dev/null
+++ b/archivers/gcpio/pkg-plist
@@ -0,0 +1,23 @@
+@comment $FreeBSD$
+bin/gcpio
+%%NLS%%share/locale/da/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/de/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/es/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/id/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/cpio.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/cpio.mo