aboutsummaryrefslogtreecommitdiff
path: root/archivers/jzip.org/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-24 06:17:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-24 06:17:31 +0000
commit0c6a2f48fb9b392029a87a7e75423b9bdff78fa5 (patch)
treebbd9eda5968e297c43442768b18cbeeb43a0f04b /archivers/jzip.org/Makefile
parent6f708353fdb3a1c8b6bd912dd4b7381b4c19929c (diff)
Notes
Diffstat (limited to 'archivers/jzip.org/Makefile')
-rw-r--r--archivers/jzip.org/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/archivers/jzip.org/Makefile b/archivers/jzip.org/Makefile
new file mode 100644
index 000000000000..2b661a255ab4
--- /dev/null
+++ b/archivers/jzip.org/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: jzip.org
+# Date created: Dec 24, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jzip.org
+PORTVERSION= 0.2.0
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jzipdotorg
+DISTNAME= ${PORTNAME}${PORTVERSION}.src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A WinZip like program written in java
+
+USE_ZIP= yes
+USE_JAVA= 1.2+
+NEED_JAVAC= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}.src
+
+do-build:
+ @cd ${WRKSRC} && ${JAVAC} -d bin src/*.java && \
+ cd bin && ${JAR} cvfm jzip.org.jar manifest/MANIFEST.MF \
+ i18n/*.properties jzipdotorg/*.class images/*.png
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/bin/${PORTNAME}.jar ${JAVAJARDIR}
+
+.include <bsd.port.mk>