aboutsummaryrefslogtreecommitdiff
path: root/archivers/lhasa/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-20 19:56:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-20 19:56:26 +0000
commit242e6f8584641aeeec366cbcdfe1818b4839497a (patch)
tree6375c1fcdcdf180bfdbcfd5271efd8a0f308f984 /archivers/lhasa/Makefile
parentbdd2491d7d683896d47e5e9c6dcfcbce4653647f (diff)
- Add archivers/lhasa
Lhasa is a command line tool and library for parsing LHA archives. Currently it is only possible to decompress archives. Compressing LHA archives may be an enhancement for future versions. The aim is to be compatible with as many different variants of the LHA file format as possible, including LArc (.lzs) and PMarc (.pma). The command line tool aims to be interface-compatible with Unix LHA tool (command line syntax and output), for backwards compatibility with tools that expect particular output. WWW: http://fragglet.github.io/lhasa/ PR: 211177 Submitted by: cs@innolan.dk
Notes
Notes: svn path=/head/; revision=418852
Diffstat (limited to 'archivers/lhasa/Makefile')
-rw-r--r--archivers/lhasa/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/archivers/lhasa/Makefile b/archivers/lhasa/Makefile
new file mode 100644
index 000000000000..9cf50308214d
--- /dev/null
+++ b/archivers/lhasa/Makefile
@@ -0,0 +1,34 @@
+# Created by: Carsten Larsen <cs@innolan.dk>
+# $FreeBSD$
+
+PORTNAME= lhasa
+PORTVERSION= 0.3.1
+CATEGORIES= archivers
+MASTER_SITES= https://soulsphere.org/projects/lhasa/ \
+ http://suyai.innolan.net/
+
+MAINTAINER= cs@innolan.dk
+COMMENT= Command line tool and library for parsing LHA archives
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf pathfix libtool
+PATHFIX_MAKEFILEIN= Makefile.am
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-silent-rules \
+ --program-suffix=sa
+INSTALL_TARGET= install-strip
+
+PORTDOCS= ChangeLog README AUTHORS TODO NEWS
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>