aboutsummaryrefslogtreecommitdiff
path: root/archivers/libarchive/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-03-21 21:29:18 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-03-21 21:29:18 +0000
commit43f255f73763c35290d4d4dc666f3e1ce63d1a3a (patch)
treee6ad0500ace6b0ac03ea2e03184b4e6773223255 /archivers/libarchive/Makefile
parentd63e931b051ce17f2b53260224679ef6f5f4e4f3 (diff)
Notes
Diffstat (limited to 'archivers/libarchive/Makefile')
-rw-r--r--archivers/libarchive/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index a0e986bfb918..0eec64cbbcc3 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 2.7.1
+PORTVERSION= 2.8.3
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -13,8 +13,11 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
+LIB_DEPENDS= lzma.0:${PORTSDIR}/archivers/xz
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GNOME= libxml2
PLIST_FILES= bin/bsdcpio \
bin/bsdtar \
@@ -23,7 +26,8 @@ PLIST_FILES= bin/bsdcpio \
lib/libarchive.a \
lib/libarchive.la \
lib/libarchive.so \
- lib/libarchive.so.9
+ lib/libarchive.so.10 \
+ lib/pkgconfig/libarchive.pc
MANCOMPRESSED= no
MAN1= bsdcpio.1 \
@@ -41,9 +45,13 @@ MAN5= cpio.5 \
mtree.5 \
tar.5
-.include <bsd.port.pre.mk>
+CFLAGS+= "-I${LOCALBASE}/include"
+MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
-regression-test:
+check:
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>