aboutsummaryrefslogtreecommitdiff
path: root/archivers/libarchive
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2017-03-19 02:54:58 +0000
committerGreg Lewis <glewis@FreeBSD.org>2017-03-19 02:54:58 +0000
commitdc1feb606d8d520938b6106d649dd9161598591e (patch)
treebb58f47d4bca6997f5ed8436b12d9c362a6e8ad3 /archivers/libarchive
parent1342dc16570b928b4db24c61f898013f9b93a312 (diff)
downloadports-dc1feb606d8d520938b6106d649dd9161598591e.tar.gz
ports-dc1feb606d8d520938b6106d649dd9161598591e.zip
. Update to 3.3.1.
. Make it work with LibreSSL [1] Submitted by: naddy@ [1]
Notes
Notes: svn path=/head/; revision=436472
Diffstat (limited to 'archivers/libarchive')
-rw-r--r--archivers/libarchive/Makefile4
-rw-r--r--archivers/libarchive/distinfo6
-rw-r--r--archivers/libarchive/files/libarchive-archive_openssl_evp_private.h11
-rw-r--r--archivers/libarchive/files/libarchive-archive_openssl_hmac_private.h11
4 files changed, 27 insertions, 5 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 526ba5873568..4e5b040db9df 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 3.2.2
+PORTVERSION= 3.3.1
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= http://libarchive.org/downloads/
@@ -35,7 +35,7 @@ PLIST_FILES= bin/bsdcat \
lib/libarchive.a \
lib/libarchive.so \
lib/libarchive.so.13 \
- lib/libarchive.so.13.2.2 \
+ lib/libarchive.so.13.3.1 \
libdata/pkgconfig/libarchive.pc \
man/man1/bsdcat.1.gz \
man/man1/bsdcpio.1.gz \
diff --git a/archivers/libarchive/distinfo b/archivers/libarchive/distinfo
index 00a324dcf08a..3080e3ddf611 100644
--- a/archivers/libarchive/distinfo
+++ b/archivers/libarchive/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477363506
-SHA256 (libarchive-3.2.2.tar.gz) = 691c194ee132d1f0f7a42541f091db811bc2e56f7107e9121be2bc8c04f1060f
-SIZE (libarchive-3.2.2.tar.gz) = 5458241
+TIMESTAMP = 1489875854
+SHA256 (libarchive-3.3.1.tar.gz) = 29ca5bd1624ca5a007aa57e16080262ab4379dbf8797f5c52f7ea74a3b0424e7
+SIZE (libarchive-3.3.1.tar.gz) = 6219943
diff --git a/archivers/libarchive/files/libarchive-archive_openssl_evp_private.h b/archivers/libarchive/files/libarchive-archive_openssl_evp_private.h
new file mode 100644
index 000000000000..d07b8a0f3277
--- /dev/null
+++ b/archivers/libarchive/files/libarchive-archive_openssl_evp_private.h
@@ -0,0 +1,11 @@
+--- libarchive/archive_openssl_evp_private.h.orig Sun Jan 29 06:06:27 2017
++++ libarchive/archive_openssl_evp_private.h Fri Mar 10 12:53:43 2017
+@@ -28,7 +28,7 @@
+ #include <openssl/evp.h>
+ #include <openssl/opensslv.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ #include <stdlib.h> /* malloc, free */
+ #include <string.h> /* memset */
+ static inline EVP_MD_CTX *EVP_MD_CTX_new(void)
diff --git a/archivers/libarchive/files/libarchive-archive_openssl_hmac_private.h b/archivers/libarchive/files/libarchive-archive_openssl_hmac_private.h
new file mode 100644
index 000000000000..aa87a19c86a4
--- /dev/null
+++ b/archivers/libarchive/files/libarchive-archive_openssl_hmac_private.h
@@ -0,0 +1,11 @@
+--- libarchive/archive_openssl_hmac_private.h.orig Sun Jan 29 06:06:27 2017
++++ libarchive/archive_openssl_hmac_private.h Fri Mar 10 12:53:43 2017
+@@ -28,7 +28,7 @@
+ #include <openssl/hmac.h>
+ #include <openssl/opensslv.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ #include <stdlib.h> /* malloc, free */
+ #include <string.h> /* memset */
+ static inline HMAC_CTX *HMAC_CTX_new(void)