aboutsummaryrefslogtreecommitdiff
path: root/archivers/libdynamite/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-14 00:09:25 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-14 00:09:25 +0000
commitd74c9bcddfe138a550ed19378054d2f5abe4d739 (patch)
tree7543759ac1eff98435af96fc1be62c7e15f7fe3e /archivers/libdynamite/Makefile
parentf99287805e77121d631eb874c0e14bb5854c9358 (diff)
downloadports-d74c9bcddfe138a550ed19378054d2f5abe4d739.tar.gz
ports-d74c9bcddfe138a550ed19378054d2f5abe4d739.zip
Notes
Diffstat (limited to 'archivers/libdynamite/Makefile')
-rw-r--r--archivers/libdynamite/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/archivers/libdynamite/Makefile b/archivers/libdynamite/Makefile
new file mode 100644
index 000000000000..514958e39a85
--- /dev/null
+++ b/archivers/libdynamite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: dynamite
+# Date Created: 10 January 2005
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynamite
+PORTVERSION= 0.1
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Decompress data compressed with PKWARE Data Compression Library
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/lib/libdynamite.c
+.endif
+
+.include <bsd.port.post.mk>