aboutsummaryrefslogtreecommitdiff
path: root/archivers/libpar2/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:48:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:48:21 +0000
commite7f6d9c0ae9399af670ee074a9fd5e39cd2451d9 (patch)
tree95ce027e702cabbc8a6d3b3837e0e0e731ff14b3 /archivers/libpar2/Makefile
parented24cea936f98f394c01a2e183047bf05a34ec27 (diff)
[NEW PORT] archivers/libpar2 Reusable library for manipulating par2 files
Libpar2 is a library for creating and using PAR2 files to detect damage in data files and repair them if necessary. It can be used with any kind of file. Par files are especially popular on Usenet. Libpar2 is extracted from par2cmdline, and distributed separately. WWW: http://parchive.sourceforge.net/ PR: ports/126578 Submitted by: Jeff Burchell <toxic@doobie.com>
Notes
Notes: svn path=/head/; revision=218714
Diffstat (limited to 'archivers/libpar2/Makefile')
-rw-r--r--archivers/libpar2/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/archivers/libpar2/Makefile b/archivers/libpar2/Makefile
new file mode 100644
index 000000000000..2dc27d4d854a
--- /dev/null
+++ b/archivers/libpar2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libpar2
+# Date created: 16 Aug 2008
+# Whom: Jeff Burchell <toxic@doobie.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpar2
+PORTVERSION= 0.2
+PORTREVISION= 1
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= parchive
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= toxic@doobie.com
+COMMENT= A library for manipulating par2 files, extracted from par2cmdline
+
+LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
+USE_LDCONFIG= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>