aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzma
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-24 19:00:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-24 19:00:14 +0000
commitc02da56a8b05efbe11b604cacb63626d8af15097 (patch)
tree9b6c903cd7add783eb32c3cfc7af91163205ed78 /archivers/lzma
parent295112e7daa791ff69f3c399e28bdb5099eb641f (diff)
downloadports-c02da56a8b05efbe11b604cacb63626d8af15097.tar.gz
ports-c02da56a8b05efbe11b604cacb63626d8af15097.zip
Notes
Diffstat (limited to 'archivers/lzma')
-rw-r--r--archivers/lzma/Makefile16
-rw-r--r--archivers/lzma/distinfo6
2 files changed, 16 insertions, 6 deletions
diff --git a/archivers/lzma/Makefile b/archivers/lzma/Makefile
index 44b931e33b48..5700fd2ad73a 100644
--- a/archivers/lzma/Makefile
+++ b/archivers/lzma/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lzma
-PORTVERSION= 4.58
+PORTVERSION= 4.60
CATEGORIES= archivers
MASTER_SITES= SFE/sevenzip
DISTNAME= lzma${PORTVERSION:S/.//g}
@@ -24,11 +24,18 @@ BUILD_WRKSRC= ${WRKSRC}/CPP/7zip/Compress/LZMA_Alone
MAKEFILE= makefile.gcc
PLIST_FILES= bin/${PORTNAME}
CFLAGS+= -D_LZMA_SYSTEM_SIZE_T
+.ifdef(WITH_LZMA_PROB32)
+#increase the speed of decoding on some 32-bit CPUs, at the expense of doubled
+#memory usage for CLzmaDec::probs
+CFLAGS+= -D_LZMA_PROB32
+.endif
+.ifdef(WITH_LZMA_SIZE_OPT)
+#enable some optimizations in LZMA Decoder to get smaller executable code
+CFLAGS+= -D_LZMA_SIZE_OPT
+.endif
PORTDOCS= 7zC.txt 7zFormat.txt Methods.txt history.txt lzma.txt
post-patch:
- @${REINPLACE_CMD} -e 's|4\.56|${DISTVERSION}|' \
- ${BUILD_WRKSRC}/LzmaAlone.cpp
@${REINPLACE_CMD} -e '/bool Open(LPCTSTR fileName, DWORD creationDisposition)/,/}/d'\
${WRKSRC}/CPP/7zip/Common/FileStreams.h
@${REINPLACE_CMD} -e \
@@ -42,4 +49,7 @@ do-install:
@cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
+regression-test: build
+ ${BUILD_WRKSRC}/${PORTNAME} b
+
.include <bsd.port.mk>
diff --git a/archivers/lzma/distinfo b/archivers/lzma/distinfo
index 3ebd7b9546ed..bf4a000c5298 100644
--- a/archivers/lzma/distinfo
+++ b/archivers/lzma/distinfo
@@ -1,3 +1,3 @@
-MD5 (lzma458.tar.bz2) = 3cd59ed43ed5cf24202b435dae8deb28
-SHA256 (lzma458.tar.bz2) = 787801737498b018d67f413deddbc32fbde83aa83c6cac53547b85a1344bc436
-SIZE (lzma458.tar.bz2) = 309128
+MD5 (lzma460.tar.bz2) = ba060723502e15256c15debae611909a
+SHA256 (lzma460.tar.bz2) = 9e6140563f19ca58c31a8e233cdad652269a758aaddc07b96f3655b19f892c1b
+SIZE (lzma460.tar.bz2) = 308767