aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzo2/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-03-24 23:58:19 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-03-24 23:58:19 +0000
commite8f9110919767432a092905a1c48fae483c06937 (patch)
tree7c7f04ed7bfaa59e257346380c63705d695b55be /archivers/lzo2/Makefile
parent3b073349d9bf8a97b67b1c89b17d3c088b709f50 (diff)
downloadports-e8f9110919767432a092905a1c48fae483c06937.tar.gz
ports-e8f9110919767432a092905a1c48fae483c06937.zip
Notes
Diffstat (limited to 'archivers/lzo2/Makefile')
-rw-r--r--archivers/lzo2/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/archivers/lzo2/Makefile b/archivers/lzo2/Makefile
index 8ed8b86413cc..dd1250478f8f 100644
--- a/archivers/lzo2/Makefile
+++ b/archivers/lzo2/Makefile
@@ -16,12 +16,12 @@ LICENSE= GPLv2
USES= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --docdir=${DOCSDIR}
+CONFIGURE_ARGS= --enable-shared --docdir=${DOCSDIR} --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS EXAMPLES
-DOCS_INSTALL_TARGET_OFF= install-exec install-pkgincludeHEADERS
+DOCS_INSTALL_TARGET_OFF= install-exec install-pkgincludeHEADERS install-pkgconfigDATA
post-build:
.if !defined(WITHOUT_CHECKS)
@@ -40,9 +40,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}/
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/[a-z]*.[ch] ${STAGEDIR}${EXAMPLESDIR}/
- ${MKDIR} ${STAGEDIR}${PREFIX}/libdata/pkgconfig
- ${INSTALL_DATA} ${WRKSRC}/lzo2.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
- ${RM} ${STAGEDIR}${PREFIX}/lib/pkgconfig/lzo2.pc
- d="${STAGEDIR}${PREFIX}/lib/pkgconfig" ; if test -d "$$d" ; then ${RMDIR} "$$d" ; fi
.include <bsd.port.mk>