aboutsummaryrefslogtreecommitdiff
path: root/archivers/nwreckdum
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-03-09 21:49:57 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-03-09 21:49:57 +0000
commitb434c5de9468a27e4c53850d971d1f903d3248cc (patch)
treeb8ef2e378b722808c00f20f32435169937df9752 /archivers/nwreckdum
parente91f9eb409cd0cef122a96708beb27d2967b9d30 (diff)
downloadports-b434c5de9468a27e4c53850d971d1f903d3248cc.tar.gz
ports-b434c5de9468a27e4c53850d971d1f903d3248cc.zip
Make this port actually usable on arches were sizeof(long) != 4.
Reported by: alepulver Tested on: amd64, ia64
Notes
Notes: svn path=/head/; revision=250781
Diffstat (limited to 'archivers/nwreckdum')
-rw-r--r--archivers/nwreckdum/Makefile2
-rw-r--r--archivers/nwreckdum/files/patch-nwreckdu.c7
2 files changed, 7 insertions, 2 deletions
diff --git a/archivers/nwreckdum/Makefile b/archivers/nwreckdum/Makefile
index 36b06525cd72..d7c599e7cc78 100644
--- a/archivers/nwreckdum/Makefile
+++ b/archivers/nwreckdum/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nwreckdum
PORTVERSION= 0.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers games
MASTER_SITES= http://freebsd.nsu.ru/distfiles/
diff --git a/archivers/nwreckdum/files/patch-nwreckdu.c b/archivers/nwreckdum/files/patch-nwreckdu.c
index 81ac5d59c2b6..4b301f2c88e4 100644
--- a/archivers/nwreckdum/files/patch-nwreckdu.c
+++ b/archivers/nwreckdum/files/patch-nwreckdu.c
@@ -1,6 +1,11 @@
--- nwreckdu.c.orig Mon Jun 8 17:47:02 1998
+++ nwreckdu.c Fri Nov 3 02:30:05 2006
-@@ -27,7 +27,7 @@
+@@ -23,11 +23,11 @@
+
+ typedef struct {
+ char name[56];
+- unsigned long offset, length;
++ uint32_t offset, length;
} dirrec;
int asmpak(FILE *);