aboutsummaryrefslogtreecommitdiff
path: root/archivers/ocaml-bz2/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-02-25 14:43:45 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-02-25 14:43:45 +0000
commitecb9aba10ac495c84ba9a4736283fe3be2c5de91 (patch)
tree11b5c35589c9a3892817a994cafae6aa15271141 /archivers/ocaml-bz2/Makefile
parente4934b425255045add2d1104fef4eb01cdd1ed83 (diff)
downloadports-ecb9aba10ac495c84ba9a4736283fe3be2c5de91.tar.gz
ports-ecb9aba10ac495c84ba9a4736283fe3be2c5de91.zip
Notes
Diffstat (limited to 'archivers/ocaml-bz2/Makefile')
-rw-r--r--archivers/ocaml-bz2/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/archivers/ocaml-bz2/Makefile b/archivers/ocaml-bz2/Makefile
new file mode 100644
index 000000000000..9fe6b0fcf0bc
--- /dev/null
+++ b/archivers/ocaml-bz2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ocaml-bz2
+# Date created: 2009-02-24
+# Whom: Jaap Boender <jaapb@kerguelen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bz2
+PORTVERSION= 0.6.0
+CATEGORIES= archivers
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/72/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= caml${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= OCaml library to manipulate bz2 files
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+USE_OCAML= yes
+USE_OCAML_LDCONFIG= yes
+USE_OCAML_WASH= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.include <bsd.port.post.mk>