aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-Archive-Any-Lite/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-25 05:15:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-25 05:15:39 +0000
commit18fab61d4ddb49adee7569c569e753e0fc660118 (patch)
tree7650bd7d37dd8114e6fc7cb77e072588118f3993 /archivers/p5-Archive-Any-Lite/Makefile
parent5719c35e9ff0fb80e0e60804e43e0c2b1cfcc64a (diff)
downloadports-18fab61d4ddb49adee7569c569e753e0fc660118.tar.gz
ports-18fab61d4ddb49adee7569c569e753e0fc660118.zip
Notes
Diffstat (limited to 'archivers/p5-Archive-Any-Lite/Makefile')
-rw-r--r--archivers/p5-Archive-Any-Lite/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/archivers/p5-Archive-Any-Lite/Makefile b/archivers/p5-Archive-Any-Lite/Makefile
new file mode 100644
index 000000000000..848b3a178726
--- /dev/null
+++ b/archivers/p5-Archive-Any-Lite/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Archive-Any-Lite
+PORTVERSION= 0.07
+CATEGORIES= archivers perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple CPAN package extractor
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Pod>=1.18:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ p5-Test-UseAllModules>=0.10:${PORTSDIR}/devel/p5-Test-UseAllModules
+
+USE_PERL5= configure
+USES= perl5
+
+MAN3= Archive::Any::Lite.3
+
+.include <bsd.port.mk>