aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-Archive-Peek
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2011-10-26 14:30:41 +0000
committerLars Thegler <lth@FreeBSD.org>2011-10-26 14:30:41 +0000
commitf1eae103545dd28ef6c96d7d5b90b4bbf0ca1c21 (patch)
treec6cf4072b965b1fffd291b370ad07fb7fc2547e1 /archivers/p5-Archive-Peek
parent906ddb323f6495e525406bc98836b0927a20f639 (diff)
downloadports-f1eae103545dd28ef6c96d7d5b90b4bbf0ca1c21.tar.gz
ports-f1eae103545dd28ef6c96d7d5b90b4bbf0ca1c21.zip
Notes
Diffstat (limited to 'archivers/p5-Archive-Peek')
-rw-r--r--archivers/p5-Archive-Peek/Makefile32
-rw-r--r--archivers/p5-Archive-Peek/distinfo2
-rw-r--r--archivers/p5-Archive-Peek/pkg-descr4
-rw-r--r--archivers/p5-Archive-Peek/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/archivers/p5-Archive-Peek/Makefile b/archivers/p5-Archive-Peek/Makefile
new file mode 100644
index 000000000000..1b289dc6c8a3
--- /dev/null
+++ b/archivers/p5-Archive-Peek/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: archivers/p5-Archive-Peek
+# Date created: 01 September 2011
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Archive-Peek
+PORTVERSION= 0.34
+CATEGORIES= archivers perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Peek into archives without extracting them
+
+BUILD_DEPENDS= p5-Archive-Tar>=0:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod
+
+PERL_CONFIGURE= yes
+
+MAN3= Archive::Peek.3
+
+regression-test: build
+ cd ${WRKSRC}/ && ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-Archive-Peek/distinfo b/archivers/p5-Archive-Peek/distinfo
new file mode 100644
index 000000000000..781ee788cdff
--- /dev/null
+++ b/archivers/p5-Archive-Peek/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Archive-Peek-0.34.tar.gz) = 2c0f8bb48313189bc03faa94632bb2d6abd6d4a4927e5b8e85a1ecc300aa61c6
+SIZE (Archive-Peek-0.34.tar.gz) = 3581
diff --git a/archivers/p5-Archive-Peek/pkg-descr b/archivers/p5-Archive-Peek/pkg-descr
new file mode 100644
index 000000000000..be7fdd525342
--- /dev/null
+++ b/archivers/p5-Archive-Peek/pkg-descr
@@ -0,0 +1,4 @@
+This module lets you peek into archives without extracting them.
+It currently supports tar files and zip files.
+
+WWW: http://search.cpan.org/dist/Archive-Peek/
diff --git a/archivers/p5-Archive-Peek/pkg-plist b/archivers/p5-Archive-Peek/pkg-plist
new file mode 100644
index 000000000000..3e36bab4b434
--- /dev/null
+++ b/archivers/p5-Archive-Peek/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Archive/Peek/Zip.pm
+%%SITE_PERL%%/Archive/Peek/Tar.pm
+%%SITE_PERL%%/Archive/Peek.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Peek/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Peek
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive
+@dirrmtry %%SITE_PERL%%/Archive/Peek
+@dirrmtry %%SITE_PERL%%/Archive