aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-Compress-LZO
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 14:18:27 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 14:18:27 +0000
commitad04e16bfd5a8704332f60b46a2e9f4bcd288256 (patch)
tree1e3c2fee8f589a8f8dad7d1364faeec2b912ecc8 /archivers/p5-Compress-LZO
parenta0520c1594c80873d1dbc023f1551d518859e606 (diff)
downloadports-ad04e16bfd5a8704332f60b46a2e9f4bcd288256.tar.gz
ports-ad04e16bfd5a8704332f60b46a2e9f4bcd288256.zip
Notes
Diffstat (limited to 'archivers/p5-Compress-LZO')
-rw-r--r--archivers/p5-Compress-LZO/Makefile27
-rw-r--r--archivers/p5-Compress-LZO/distinfo3
-rw-r--r--archivers/p5-Compress-LZO/files/patch-Makefile.PL11
-rw-r--r--archivers/p5-Compress-LZO/pkg-descr6
-rw-r--r--archivers/p5-Compress-LZO/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/archivers/p5-Compress-LZO/Makefile b/archivers/p5-Compress-LZO/Makefile
new file mode 100644
index 000000000000..2fc213193993
--- /dev/null
+++ b/archivers/p5-Compress-LZO/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Compress-LZO
+# Date created: 2006-09-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Compress-LZO
+PORTVERSION= 1.08
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Compress
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Interface to the LZO compression library
+
+LIB_DEPENDS= lzo:${PORTSDIR}/archivers/lzo
+
+PERL_CONFIGURE= yes
+
+post-patch:
+ ${PERL} -pi -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/Makefile.PL
+
+MAN3= Compress::LZO.3
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-Compress-LZO/distinfo b/archivers/p5-Compress-LZO/distinfo
new file mode 100644
index 000000000000..4595b095cd82
--- /dev/null
+++ b/archivers/p5-Compress-LZO/distinfo
@@ -0,0 +1,3 @@
+MD5 (Compress-LZO-1.08.tar.gz) = 4266ea0cb23817dd02ead4f983c2604f
+SHA256 (Compress-LZO-1.08.tar.gz) = cabf52349c12e7044189758093a8f7a56bae85850c1e772d977a7695070f4c06
+SIZE (Compress-LZO-1.08.tar.gz) = 12480
diff --git a/archivers/p5-Compress-LZO/files/patch-Makefile.PL b/archivers/p5-Compress-LZO/files/patch-Makefile.PL
new file mode 100644
index 000000000000..2c8a9667db80
--- /dev/null
+++ b/archivers/p5-Compress-LZO/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Sun Sep 10 23:56:49 2006
++++ Makefile.PL Sun Sep 10 23:57:27 2006
+@@ -14,6 +14,8 @@
+ # installed.
+
+ #$LZO_LIB = '-L/usr/local/lib';
++$LZO_INCLUDE = '-I%%LOCALBASE%%/include';
++$LZO_LIB = '-L%%LOCALBASE%%/lib';
+
+
+ # It shouldn't be necessary to change anything from here on.
diff --git a/archivers/p5-Compress-LZO/pkg-descr b/archivers/p5-Compress-LZO/pkg-descr
new file mode 100644
index 000000000000..39b5d37cb892
--- /dev/null
+++ b/archivers/p5-Compress-LZO/pkg-descr
@@ -0,0 +1,6 @@
+The Compress::LZO module provides a Perl interface to the LZO
+compression library (see "AUTHOR" for details about where to get LZO).
+A relevant subset of the functionality provided by LZO is available in
+Compress::LZO.
+
+WWW: http://search.cpan.org/dist/Compress-LZO/
diff --git a/archivers/p5-Compress-LZO/pkg-plist b/archivers/p5-Compress-LZO/pkg-plist
new file mode 100644
index 000000000000..5e36c50dc8e3
--- /dev/null
+++ b/archivers/p5-Compress-LZO/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Compress/LZO.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZO/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZO/LZO.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZO/LZO.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZO/autosplit.ix
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZO
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Compress