aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-IO-Compress-Zlib
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2006-12-03 11:39:43 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2006-12-03 11:39:43 +0000
commit553532006ec4fae4cd46aa5b17b20016db505ce3 (patch)
treea620a5face7268fd74bd6b32b2d537c8ed1f1936 /archivers/p5-IO-Compress-Zlib
parentde2286382e6d80017923a562d690e1ec14dc8c13 (diff)
New port: p5-IO=Compress-Zlib.
A Perl5 interface to allow reading and writing of RFC 1950, 1951, 1952 (i.e. gzip) and zip files/buffers.
Notes
Notes: svn path=/head/; revision=178671
Diffstat (limited to 'archivers/p5-IO-Compress-Zlib')
-rw-r--r--archivers/p5-IO-Compress-Zlib/Makefile30
-rw-r--r--archivers/p5-IO-Compress-Zlib/distinfo3
-rw-r--r--archivers/p5-IO-Compress-Zlib/pkg-descr2
-rw-r--r--archivers/p5-IO-Compress-Zlib/pkg-plist16
4 files changed, 51 insertions, 0 deletions
diff --git a/archivers/p5-IO-Compress-Zlib/Makefile b/archivers/p5-IO-Compress-Zlib/Makefile
new file mode 100644
index 000000000000..04eceacfc7ac
--- /dev/null
+++ b/archivers/p5-IO-Compress-Zlib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-IO-Compress-Zlib
+# Date created: 3 December 2006
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Compress-Zlib
+PORTVERSION= 2.001
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Perl5 interface for reading and writing of (g)zip files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Raw/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
+ ${SITE_PERL}/IO/Compress/Base.pm:${PORTSDIR}/archivers/p5-IO-Compress-Base
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= IO::Uncompress::RawInflate.3 IO::Uncompress::Unzip.3 \
+ IO::Uncompress::Inflate.3 IO::Compress::Deflate.3 \
+ IO::Compress::Zip.3 IO::Uncompress::Gunzip.3 \
+ IO::Compress::RawDeflate.3 IO::Uncompress::AnyInflate.3 \
+ IO::Compress::Gzip.3
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-IO-Compress-Zlib/distinfo b/archivers/p5-IO-Compress-Zlib/distinfo
new file mode 100644
index 000000000000..034ad6016763
--- /dev/null
+++ b/archivers/p5-IO-Compress-Zlib/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-Compress-Zlib-2.001.tar.gz) = 265c31ec11a220999b6b29d47e3baddc
+SHA256 (IO-Compress-Zlib-2.001.tar.gz) = a698c38b5423d427dfb4d5b2c71b78c3c64fcdfd5d5eb01dc0288668330a79b7
+SIZE (IO-Compress-Zlib-2.001.tar.gz) = 131858
diff --git a/archivers/p5-IO-Compress-Zlib/pkg-descr b/archivers/p5-IO-Compress-Zlib/pkg-descr
new file mode 100644
index 000000000000..b50daf4eacfc
--- /dev/null
+++ b/archivers/p5-IO-Compress-Zlib/pkg-descr
@@ -0,0 +1,2 @@
+A Perl5 interface to allow reading and writing of RFC 1950, 1951, 1952
+(i.e. gzip) and zip files/buffers.
diff --git a/archivers/p5-IO-Compress-Zlib/pkg-plist b/archivers/p5-IO-Compress-Zlib/pkg-plist
new file mode 100644
index 000000000000..ad76182ce6f3
--- /dev/null
+++ b/archivers/p5-IO-Compress-Zlib/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/IO/Compress/Zlib/Constants.pm
+%%SITE_PERL%%/IO/Compress/Zip/Constants.pm
+%%SITE_PERL%%/IO/Uncompress/RawInflate.pm
+%%SITE_PERL%%/IO/Uncompress/Inflate.pm
+%%SITE_PERL%%/IO/Uncompress/Unzip.pm
+%%SITE_PERL%%/IO/Uncompress/Gunzip.pm
+%%SITE_PERL%%/IO/Uncompress/AnyInflate.pm
+%%SITE_PERL%%/IO/Uncompress/Adapter/Identity.pm
+%%SITE_PERL%%/IO/Uncompress/Adapter/Inflate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Compress/Zlib/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Compress/Zlib
+@dirrm %%SITE_PERL%%/IO/Uncompress/Adapter
+@dirrmtry %%SITE_PERL%%/IO/Uncompress
+@dirrm %%SITE_PERL%%/IO/Compress/Zip
+@dirrm %%SITE_PERL%%/IO/Compress/Zlib
+@dirrmtry %%SITE_PERL%%/IO/Compress