aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2004-11-26 01:19:10 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2004-11-26 01:19:10 +0000
commitc734c7be74ca8d3762ebf314f04b3572036020d4 (patch)
treee7dfd7bb5e8ca95bd96c234d011bfb0da4e19ff6 /archivers/p7zip
parent626e4b86a80bda267ca73fe79e9f7883b66b7a1c (diff)
downloadports-c734c7be74ca8d3762ebf314f04b3572036020d4.tar.gz
ports-c734c7be74ca8d3762ebf314f04b3572036020d4.zip
Notes
Diffstat (limited to 'archivers/p7zip')
-rw-r--r--archivers/p7zip/Makefile40
-rw-r--r--archivers/p7zip/distinfo4
-rw-r--r--archivers/p7zip/files/7z4
-rw-r--r--archivers/p7zip/files/patch-7zip_Crypto_RarAES_sha1.cpp10
-rw-r--r--archivers/p7zip/pkg-descr14
-rw-r--r--archivers/p7zip/pkg-plist54
6 files changed, 36 insertions, 90 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index 1f0bd9d4a08a..a2adc9624acd 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= p7zip
-PORTVERSION= 0.91
+PORTVERSION= 4.12
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= p7zip
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= Command line versions of 7-zip
@@ -18,10 +18,12 @@ COMMENT= Command line versions of 7-zip
USE_BZIP2= yes
USE_GMAKE= yes
MAKEFILE= makefile
-ONLY_FOR_ARCHS= alpha amd64 i386 ia64
-USE_REINPLACE= yes
-MMACHINE= ${WRKSRC}/makefile.machine
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+PLIST_FILES= "@unexec ${RM} %D/bin/7z"
+PLIST_FILES+= bin/7za
+PLIST_FILES+= "@exec ${LN} -sf 7za %D/bin/7z"
+PORTDOCS= *
.include <bsd.port.pre.mk>
@@ -30,22 +32,22 @@ BROKEN= 'Requires wchar functions (mbrtowc(3) etc.) for compilation'
.endif
post-patch:
- ${ECHO} "LOCAL_LIBS= ${PTHREAD_LIBS}" > ${MMACHINE}
- ${ECHO} "LOCAL_FLAGS+= ${PTHREAD_CFLAGS}" >> ${MMACHINE}
- ${REINPLACE_CMD} -e 's/-O2/${CXXFLAGS}/' ${WRKSRC}/makefile.glb
+ ${SED} -e 's/-O2/${CFLAGS} ${PTHREAD_CFLAGS}/' \
+ -e 's/g\+\+/${CXX}/' \
+ -e 's/gcc/${CC}/' \
+ -e '/LITTLE_ENDIAN/d' \
+ -e 's/-lc_r/${PTHREAD_LIBS}/' \
+ ${WRKSRC}/makefile.freebsd_x86 > ${WRKSRC}/makefile.machine
do-install:
- ${MKDIR} ${PREFIX}/libexec/p7zip/Codecs
- ${MKDIR} ${PREFIX}/libexec/p7zip/Formats
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/7z ${PREFIX}/libexec/p7zip
${INSTALL_PROGRAM} ${WRKSRC}/bin/7za ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/bin/Codecs/* ${PREFIX}/libexec/p7zip/Codecs
- ${INSTALL_DATA} ${WRKSRC}/bin/Formats/* ${PREFIX}/libexec/p7zip/Formats
- ${INSTALL_SCRIPT} ${FILESDIR}/7z ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/doc/p7zip/commands
- ${MKDIR} ${PREFIX}/share/doc/p7zip/switches
- ${INSTALL_DATA} ${WRKSRC}/html/cmdline/*.htm ${PREFIX}/share/doc/p7zip
- ${INSTALL_DATA} ${WRKSRC}/html/cmdline/commands/* ${PREFIX}/share/doc/p7zip/commands
- ${INSTALL_DATA} ${WRKSRC}/html/cmdline/switches/* ${PREFIX}/share/doc/p7zip/switches
+ ${LN} -sf 7za ${PREFIX}/bin/7z
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${PAX} -rw -s,${WRKSRC}/DOCS,, ${WRKSRC}/DOCS ${DOCSDIR}
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ ${FIND} ${DOCSDIR} -type d | ${XARGS} ${CHMOD} 755
+ ${FIND} ${DOCSDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endif
.include <bsd.port.post.mk>
diff --git a/archivers/p7zip/distinfo b/archivers/p7zip/distinfo
index e3850cd107ab..88f0dd643323 100644
--- a/archivers/p7zip/distinfo
+++ b/archivers/p7zip/distinfo
@@ -1,2 +1,2 @@
-MD5 (p7zip_0.91.tar.bz2) = 8c6a7b49f360917cbdd8391f3a926a19
-SIZE (p7zip_0.91.tar.bz2) = 448147
+MD5 (p7zip_4.12_src.tar.bz2) = 82d4859d8e3b30a54ac5ad6a12b16e10
+SIZE (p7zip_4.12_src.tar.bz2) = 454996
diff --git a/archivers/p7zip/files/7z b/archivers/p7zip/files/7z
deleted file mode 100644
index 2007b3339f54..000000000000
--- a/archivers/p7zip/files/7z
+++ /dev/null
@@ -1,4 +0,0 @@
-#! /bin/sh
-PROG=$(dirname $(realpath $0))/../libexec/p7zip/7z
-
-$PROG "$@"
diff --git a/archivers/p7zip/files/patch-7zip_Crypto_RarAES_sha1.cpp b/archivers/p7zip/files/patch-7zip_Crypto_RarAES_sha1.cpp
new file mode 100644
index 000000000000..fca79a90126e
--- /dev/null
+++ b/archivers/p7zip/files/patch-7zip_Crypto_RarAES_sha1.cpp
@@ -0,0 +1,10 @@
+--- 7zip/Crypto/RarAES/sha1.cpp.orig Sat Oct 30 01:04:01 2004
++++ 7zip/Crypto/RarAES/sha1.cpp Fri Nov 19 09:41:13 2004
+@@ -4,6 +4,7 @@
+ #include "StdAfx.h"
+
+ #include "sha1.h"
++#include <sys/endian.h>
+
+ /*
+ SHA-1 in C
diff --git a/archivers/p7zip/pkg-descr b/archivers/p7zip/pkg-descr
index b25bb3ee98ee..184dfc8277b8 100644
--- a/archivers/p7zip/pkg-descr
+++ b/archivers/p7zip/pkg-descr
@@ -1,14 +1,6 @@
-p7zip is a port of 7z.exe and 7za.exe for Unix.
-
-7z and 7za are command line version of 7-zip, see http://www.7-zip.org/.
-
-7-Zip is a file archiver with highest compression ratio.
-
-Currently, p7zip (like 7-zip) supports only little-endian machine.
-
-7z uses shared libraries and supports more archive formats, otherwise
-7z and 7za work the same. They didn't come with a manpage, html
-commandline documentation will be installed in %%PREFIX%%/share/doc/p7zip/
+p7zip is a port of 7za.exe for Unix.
+7za is a command line version of 7-zip, a file archiver with highest
+compression ratio with LZMA algorithm.
WWW: http://p7zip.sourceforge.net/
diff --git a/archivers/p7zip/pkg-plist b/archivers/p7zip/pkg-plist
deleted file mode 100644
index cda947a89174..000000000000
--- a/archivers/p7zip/pkg-plist
+++ /dev/null
@@ -1,54 +0,0 @@
-bin/7z
-bin/7za
-libexec/p7zip/7z
-libexec/p7zip/Codecs/7zAES.dll
-libexec/p7zip/Codecs/BZip2.dll
-libexec/p7zip/Codecs/Copy.dll
-libexec/p7zip/Codecs/Implode.dll
-libexec/p7zip/Codecs/PPMD.dll
-libexec/p7zip/Codecs/AES.dll
-libexec/p7zip/Codecs/Branch.dll
-libexec/p7zip/Codecs/Deflate.dll
-libexec/p7zip/Codecs/LZMA.dll
-libexec/p7zip/Codecs/Swap.dll
-libexec/p7zip/Formats/7z.dll
-libexec/p7zip/Formats/Rar.dll
-libexec/p7zip/Formats/Tar.dll
-libexec/p7zip/Formats/Zip.dll
-libexec/p7zip/Formats/arj.dll
-libexec/p7zip/Formats/bz2.dll
-libexec/p7zip/Formats/cab.dll
-libexec/p7zip/Formats/cpio.dll
-libexec/p7zip/Formats/deb.dll
-libexec/p7zip/Formats/gz.dll
-libexec/p7zip/Formats/rpm.dll
-libexec/p7zip/Formats/split.dll
-%%PORTDOCS%%%%DOCSDIR%%/index.htm
-%%PORTDOCS%%%%DOCSDIR%%/syntax.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/add.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/delete.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/extract.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/extract_full.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/index.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/list.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/test.htm
-%%PORTDOCS%%%%DOCSDIR%%/commands/update.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/exclude.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/include.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/index.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/method.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/output_dir.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/overwrite.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/password.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/recurse.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/sfx.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/type.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/update.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/working_dir.htm
-%%PORTDOCS%%%%DOCSDIR%%/switches/yes.htm
-@dirrm libexec/p7zip/Formats
-@dirrm libexec/p7zip/Codecs
-@dirrm libexec/p7zip
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/commands
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/switches
-%%PORTDOCS%%@dirrm %%DOCSDIR%%