aboutsummaryrefslogtreecommitdiff
path: root/archivers/pear-PHP_Archiv
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-22 00:12:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-22 00:12:54 +0000
commite9bf89c8dee4ed57a3b070207c082fc3654684f5 (patch)
tree188bb92771f50e10bbcae224fee5eba37961c86d /archivers/pear-PHP_Archiv
parent2bd077b50d42ee9c55e7907c016d199fdb25f475 (diff)
downloadports-e9bf89c8dee4ed57a3b070207c082fc3654684f5.tar.gz
ports-e9bf89c8dee4ed57a3b070207c082fc3654684f5.zip
Notes
Diffstat (limited to 'archivers/pear-PHP_Archiv')
-rw-r--r--archivers/pear-PHP_Archiv/Makefile47
-rw-r--r--archivers/pear-PHP_Archiv/distinfo3
-rw-r--r--archivers/pear-PHP_Archiv/pkg-descr4
3 files changed, 54 insertions, 0 deletions
diff --git a/archivers/pear-PHP_Archiv/Makefile b/archivers/pear-PHP_Archiv/Makefile
new file mode 100644
index 000000000000..0f084e6c7c24
--- /dev/null
+++ b/archivers/pear-PHP_Archiv/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: pear-PHP_Archive
+# Date created: 20 May 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP_Archive
+PORTVERSION= 0.11.4
+CATEGORIES= archivers
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Create and Use PHP Archive files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= PHP
+FILES= Archive.php Archive/Creator.php \
+ Archive/Exception.php Archive/Manager.php
+DATA= phar_frontcontroller.tpl
+TESTS= eof.phpt filenotfound.phpt filenotfound_phar.phpt \
+ filenotfoundtest.php gopearphar.php.inc \
+ longfilename.phpt makepearphar.php.inc \
+ maketestphars.php.inc new_phar.phar \
+ normalstat.phpt normalstat_phar.phpt \
+ opendir.phpt pearindex.php phar.log \
+ phpt_test.php.inc require_once.phpt \
+ require_once_phar.phpt savetest.php \
+ seek.phpt seek_phar.phpt streamstat.phpt \
+ streamstat_phar.phpt test.php test1.php \
+ test_path.php test_phar.phar \
+ test_phar2.phar test_require.php \
+ test_tar.tar twophars.phpt \
+ filenotfound/filenotfound.phar \
+ filenotfound/makefilenotfoundphar.php.inc \
+ longfilename/longphar.phar \
+ longfilename/makelongphar.php.inc \
+ opendir/makeopendirphar.php.inc \
+ opendir/opendir.phar \
+ planet_php/default_phar.php \
+ require_once/makerequire_oncephar.php.inc \
+ require_once/require_once.phar
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/archivers/pear-PHP_Archiv/distinfo b/archivers/pear-PHP_Archiv/distinfo
new file mode 100644
index 000000000000..b399f0fe4082
--- /dev/null
+++ b/archivers/pear-PHP_Archiv/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/PHP_Archive-0.11.4.tgz) = be6dfa685d559ed445b93e4706d4ca2a
+SHA256 (PEAR/PHP_Archive-0.11.4.tgz) = 8501d03ce5306633d00191c4d313bd056c4841c856e3748507885ef238772aef
+SIZE (PEAR/PHP_Archive-0.11.4.tgz) = 83047
diff --git a/archivers/pear-PHP_Archiv/pkg-descr b/archivers/pear-PHP_Archiv/pkg-descr
new file mode 100644
index 000000000000..be8c1b4964f2
--- /dev/null
+++ b/archivers/pear-PHP_Archiv/pkg-descr
@@ -0,0 +1,4 @@
+The PHP_Archive package allows creation of self-contained cross-platform
+PHP libraries or applications, similar to Java jar files.
+
+WWW: http://pear.php.net/package/PHP_Archive/