aboutsummaryrefslogtreecommitdiff
path: root/archivers/peazip
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2015-08-19 21:20:48 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2015-08-19 21:20:48 +0000
commitf3d17bc9c286188e08ba314ae23df33c33b9d617 (patch)
treee226602f56668a3b3e71956f69166c654c40308c /archivers/peazip
parent5e4faa36019ee0c817d46008859f5b92277cd954 (diff)
downloadports-f3d17bc9c286188e08ba314ae23df33c33b9d617.tar.gz
ports-f3d17bc9c286188e08ba314ae23df33c33b9d617.zip
Notes
Diffstat (limited to 'archivers/peazip')
-rw-r--r--archivers/peazip/Makefile115
-rw-r--r--archivers/peazip/distinfo2
-rw-r--r--archivers/peazip/files/patch-peach.pas26
-rw-r--r--archivers/peazip/files/pea.in3
-rw-r--r--archivers/peazip/files/pealauncher.in3
-rw-r--r--archivers/peazip/files/peazip.in3
-rw-r--r--archivers/peazip/pkg-descr9
-rw-r--r--archivers/peazip/pkg-plist78
8 files changed, 239 insertions, 0 deletions
diff --git a/archivers/peazip/Makefile b/archivers/peazip/Makefile
new file mode 100644
index 000000000000..6097bf54345d
--- /dev/null
+++ b/archivers/peazip/Makefile
@@ -0,0 +1,115 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= peazip
+PORTVERSION= 5.7.1
+CATEGORIES= archivers
+MASTER_SITES= https://github.com/giorgiotani/PeaZip/releases/download/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free archiver and file compressor
+
+BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus \
+ fpcres:${PORTSDIR}/lang/fpc-utils
+
+USES= dos2unix zip
+USE_FPC= cairo fcl-base fcl-image fcl-process hash pasjpeg paszlib x11
+USE_GNOME= #
+
+SUB_FILES= pea pealauncher peazip
+
+DOS2UNIX_REGEX= .*\.([txt]|pas|lpi|txt)
+LAZARUS_PROJECT_FILES= project_pea.lpi project_peach.lpi project_gwrap.lpi
+LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
+LCL_UNITS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}/lcl/units/${BUILDNAME}
+LAZARUS_VER= 1.4.2
+LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
+ARCHIVER_FILES= #
+
+OPTIONS_DEFINE= 7Z ARC ZPAQ UNACE
+OPTIONS_SINGLE= LCL
+OPTIONS_SINGLE_LCL= GTK2 QT4
+
+7Z_DESC= 7z file archiver support
+ARC_DESC= Arc file archiver support
+ZPAQ_DESC= Zpaq file archiver support
+UNACE_DESC= Unace file archiver support
+GTK2_DESC= Use gtk20 interface
+QT4_DESC= Use qt4 interface
+
+OPTIONS_DEFAULT= GTK2 7Z
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MGTK2}
+USE_FPC+= gtk2
+USE_GNOME= gtk20
+LCL_PLATFORM= gtk2
+BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-gtk2
+.endif
+
+.if ${PORT_OPTIONS:MQT4}
+LIB_DEPENDS+= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
+LCL_PLATFORM= qt
+BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
+.endif
+
+.if ${PORT_OPTIONS:M7Z}
+RUN_DEPENDS+= 7z:${PORTSDIR}/archivers/p7zip
+ARCHIVER_FILES+=7z
+PLIST_SUB+= 7Z=""
+.else
+PLIST_SUB+= 7Z="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MARC}
+RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
+ARCHIVER_FILES+=arc
+PLIST_SUB+= ARC=""
+.else
+PLIST_SUB+= ARC="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MZPAQ}
+RUN_DEPENDS+= zpaq:${PORTSDIR}/archivers/paq
+ARCHIVER_FILES+=zpaq
+PLIST_SUB+= ZPAQ=""
+.else
+PLIST_SUB+= ZPAQ="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MUNACE}
+RUN_DEPENDS+= unace:${PORTSDIR}/archivers/unace
+ARCHIVER_FILES+=unace
+PLIST_SUB+= UNACE=""
+.else
+PLIST_SUB+= UNACE="@comment "
+.endif
+
+do-build:
+.for PROJECT_FILE in ${LAZARUS_PROJECT_FILES}
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${LAZBUILD_CMD} --ws=${LCL_PLATFORM} --lazarusdir=${LAZARUS_DIR} ${PROJECT_FILE}
+.endfor
+
+pre-install:
+ @${ECHO_CMD} "#" > ${WRKSRC}/altconf.txt
+ @${ECHO_CMD} "appdata" >> ${WRKSRC}/altconf.txt
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/res
+.for ARCHIVER in ${ARCHIVER_FILES}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/res/${ARCHIVER}
+ @${LN} -s ${LOCALBASE}/bin/${ARCHIVER} ${STAGEDIR}${DATADIR}/res/${ARCHIVER}/${ARCHIVER}
+.endfor
+ @cd ${WRKSRC}/res && ${COPYTREE_SHARE} "icons lang themes" ${STAGEDIR}${DATADIR}/res
+ @cd ${WRKSRC} && ${INSTALL_DATA} altconf.txt ${STAGEDIR}${DATADIR}/res && \
+ ${INSTALL_PROGRAM} pea pealauncher ${STAGEDIR}${DATADIR}/res && \
+ ${INSTALL_PROGRAM} peazip ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC}/FreeDesktop_integration && \
+ ${INSTALL_DATA} peazip.desktop ${STAGEDIR}${DESKTOPDIR} && \
+ ${INSTALL_DATA} peazip.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_SCRIPT} ${WRKDIR}/pea ${WRKDIR}/pealauncher ${WRKDIR}/peazip ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.post.mk>
diff --git a/archivers/peazip/distinfo b/archivers/peazip/distinfo
new file mode 100644
index 000000000000..a93eeb434876
--- /dev/null
+++ b/archivers/peazip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (peazip-5.7.1.src.zip) = d32c1427f911a03974ee619096267eaf289afe4652f9abebbf18d55971b5e5f3
+SIZE (peazip-5.7.1.src.zip) = 4045028
diff --git a/archivers/peazip/files/patch-peach.pas b/archivers/peazip/files/patch-peach.pas
new file mode 100644
index 000000000000..060f2c9ad7ed
--- /dev/null
+++ b/archivers/peazip/files/patch-peach.pas
@@ -0,0 +1,26 @@
+--- peach.pas.orig 2015-08-10 00:54:42.122935000 -0500
++++ peach.pas 2015-08-10 00:56:11.788970000 -0500
+@@ -4320,6 +4320,7 @@
+ APPLICATION5 = '';
+ APPLICATION6 = '';
+ APPLICATION7 = '';
++ APPLICATION8 = '';
+ {$ENDIF}
+ {$IFDEF NETBSD}
+ EXEEXT = '';
+@@ -4330,6 +4331,7 @@
+ APPLICATION5 = '';
+ APPLICATION6 = '';
+ APPLICATION7 = '';
++ APPLICATION8 = '';
+ {$ENDIF}
+ {$IFDEF DARWIN}
+ EXEEXT = '';
+@@ -4340,6 +4342,7 @@
+ APPLICATION5 = '';
+ APPLICATION6 = '';
+ APPLICATION7 = '';
++ APPLICATION8 = '';
+ {$ENDIF}
+
+ var
diff --git a/archivers/peazip/files/pea.in b/archivers/peazip/files/pea.in
new file mode 100644
index 000000000000..327da38c7ba2
--- /dev/null
+++ b/archivers/peazip/files/pea.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%%/res && exec %%DATADIR%%/res/pea "$@"
diff --git a/archivers/peazip/files/pealauncher.in b/archivers/peazip/files/pealauncher.in
new file mode 100644
index 000000000000..84b1ae47e779
--- /dev/null
+++ b/archivers/peazip/files/pealauncher.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%%/res && exec %%DATADIR%%/res/pealauncher "$@"
diff --git a/archivers/peazip/files/peazip.in b/archivers/peazip/files/peazip.in
new file mode 100644
index 000000000000..3eaceb625995
--- /dev/null
+++ b/archivers/peazip/files/peazip.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%DATADIR%%/peazip "$@"
diff --git a/archivers/peazip/pkg-descr b/archivers/peazip/pkg-descr
new file mode 100644
index 000000000000..62190cf6d24a
--- /dev/null
+++ b/archivers/peazip/pkg-descr
@@ -0,0 +1,9 @@
+PeaZip, free archiver utility, Open Source WinRar / WinZip alternative for
+Windows, Linux and FreeBSD. Compress to 7Z, ARC, BZ2, GZip, PAQ, PEA,
+self-extracting archives, TAR, WIM, XZ, ZIP files. Open 150+ file types,
+including ACE, CAB, DMG, ISO, RAR, UDF, ZIPX format. Extract, create and
+convert archives, split / join files, strong encryption, encrypted password
+manager, secure delete, find duplicate files, compute hash, export job
+definition as script to automate backup / restore.
+
+WWW: http://www.peazip.org
diff --git a/archivers/peazip/pkg-plist b/archivers/peazip/pkg-plist
new file mode 100644
index 000000000000..d516b457342d
--- /dev/null
+++ b/archivers/peazip/pkg-plist
@@ -0,0 +1,78 @@
+bin/pea
+bin/pealauncher
+bin/peazip
+share/applications/peazip.desktop
+share/pixmaps/peazip.png
+%%DATADIR%%/peazip
+%%DATADIR%%/res/altconf.txt
+%%DATADIR%%/res/icons/PeaZip.ico
+%%DATADIR%%/res/icons/PeaZip_7z.ico
+%%DATADIR%%/res/icons/PeaZip_block.ico
+%%DATADIR%%/res/icons/PeaZip_cd.ico
+%%DATADIR%%/res/icons/PeaZip_package.ico
+%%DATADIR%%/res/icons/PeaZip_rar.ico
+%%DATADIR%%/res/icons/PeaZip_zip.ico
+%%DATADIR%%/res/icons/new installer/peazip-256.bmp
+%%DATADIR%%/res/icons/new installer/peazip-icon-green.ico
+%%DATADIR%%/res/icons/new installer/peazip-icon-yellow.ico
+%%DATADIR%%/res/icons/new installer/peazip-installer-green-16.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-green-24.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-green-256.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-green-32.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-green-48.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-16.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-24.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-256.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-32.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-48.bmp
+%%DATADIR%%/res/icons/new installer/peazip-installer.png
+%%DATADIR%%/res/icons/peazip_seven.icl
+%%DATADIR%%/res/lang/ar.txt
+%%DATADIR%%/res/lang/bg.txt
+%%DATADIR%%/res/lang/by-cr.txt
+%%DATADIR%%/res/lang/by-lt.txt
+%%DATADIR%%/res/lang/chs.txt
+%%DATADIR%%/res/lang/cht.txt
+%%DATADIR%%/res/lang/cz.txt
+%%DATADIR%%/res/lang/de-uml.txt
+%%DATADIR%%/res/lang/default.txt
+%%DATADIR%%/res/lang/en-gb.txt
+%%DATADIR%%/res/lang/en.txt
+%%DATADIR%%/res/lang/es-es.txt
+%%DATADIR%%/res/lang/es-la.txt
+%%DATADIR%%/res/lang/eu.txt
+%%DATADIR%%/res/lang/fi.txt
+%%DATADIR%%/res/lang/fr.txt
+%%DATADIR%%/res/lang/gl.txt
+%%DATADIR%%/res/lang/gr.txt
+%%DATADIR%%/res/lang/hu.txt
+%%DATADIR%%/res/lang/it.txt
+%%DATADIR%%/res/lang/ja.txt
+%%DATADIR%%/res/lang/ko.txt
+%%DATADIR%%/res/lang/nl.txt
+%%DATADIR%%/res/lang/no.txt
+%%DATADIR%%/res/lang/pl.txt
+%%DATADIR%%/res/lang/pt-br.txt
+%%DATADIR%%/res/lang/pt-pt.txt
+%%DATADIR%%/res/lang/ro.txt
+%%DATADIR%%/res/lang/ru.txt
+%%DATADIR%%/res/lang/si.txt
+%%DATADIR%%/res/lang/sk.txt
+%%DATADIR%%/res/lang/sv.txt
+%%DATADIR%%/res/lang/tj.txt
+%%DATADIR%%/res/lang/tr.txt
+%%DATADIR%%/res/lang/uk.txt
+%%DATADIR%%/res/lang/uz.txt
+%%DATADIR%%/res/lang/vn.txt
+%%DATADIR%%/res/pea
+%%DATADIR%%/res/pealauncher
+%%DATADIR%%/res/themes/firecrystal.theme.7z
+%%DATADIR%%/res/themes/nographic-embedded/fm-theme.bmp
+%%DATADIR%%/res/themes/nographic-embedded/note.readme
+%%DATADIR%%/res/themes/seven-embedded/fm-theme.bmp
+%%DATADIR%%/res/themes/seven-embedded/note.readme
+%%DATADIR%%/res/themes/seven.theme.7z
+%%7Z%%%%DATADIR%%/res/7z/7z
+%%ARC%%%%DATADIR%%/res/arc/arc
+%%UNACE%%%%DATADIR%%/res/unace/unace
+%%ZPAQ%%%%DATADIR%%/res/zpaq/zpaq