aboutsummaryrefslogtreecommitdiff
path: root/archivers/pecl-lzf/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-07 12:25:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-07 12:25:49 +0000
commitc65422ba6919f6f997b29aa78d33a17a6d61d04f (patch)
tree644437471c6f36db4e587afc5967ba00b240d86d /archivers/pecl-lzf/Makefile
parentff1c72ebd7285e50f3bf07db47025ebd980684ba (diff)
downloadports-c65422ba6919f6f997b29aa78d33a17a6d61d04f.tar.gz
ports-c65422ba6919f6f997b29aa78d33a17a6d61d04f.zip
Notes
Diffstat (limited to 'archivers/pecl-lzf/Makefile')
-rw-r--r--archivers/pecl-lzf/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/archivers/pecl-lzf/Makefile b/archivers/pecl-lzf/Makefile
new file mode 100644
index 000000000000..f98784c2fd25
--- /dev/null
+++ b/archivers/pecl-lzf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pecl-lzf
+# Date created: 2006/09/07
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lzf
+PORTVERSION= 1.4
+CATEGORIES= archivers pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Handles LZF de/compression
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-lzf
+WRKSRC= ${WRKDIR}/${DISTNAME:U}
+
+OPTIONS= BETTER_COMPRESSION "Better compression ratio" off
+
+.if defined(WITH_BETTER_COMPRESSION)
+CONFIGURE_ARGS+= --enable-lzf-better-compression
+ @${ECHO_MSG} "--enable-lzf-better-compression"
+.endif
+
+.include <bsd.port.mk>