aboutsummaryrefslogtreecommitdiff
path: root/archivers/php56-zlib
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /archivers/php56-zlib
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
downloadports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.tar.gz
ports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.zip
Notes
Diffstat (limited to 'archivers/php56-zlib')
-rw-r--r--archivers/php56-zlib/Makefile10
-rw-r--r--archivers/php56-zlib/files/patch-zlib.c10
2 files changed, 20 insertions, 0 deletions
diff --git a/archivers/php56-zlib/Makefile b/archivers/php56-zlib/Makefile
new file mode 100644
index 000000000000..e9ba04011193
--- /dev/null
+++ b/archivers/php56-zlib/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php56-zlib/files/patch-zlib.c b/archivers/php56-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..0e88fee9c5bf
--- /dev/null
+++ b/archivers/php56-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2012-07-09 15:25:31.000000000 +0200
++++ zlib.c 2012-07-09 15:26:07.000000000 +0200
+@@ -957,6 +957,7 @@
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+
+ php_zlib_output_compression_start(TSRMLS_C);