aboutsummaryrefslogtreecommitdiff
path: root/archivers/php72-zlib
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-11-16 10:48:48 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-11-16 10:48:48 +0000
commit687591dd75e7bc33dfeb597493d97e5baaf89f1d (patch)
treea2ff3d816b255016827738be132f8fc8bff8f5d9 /archivers/php72-zlib
parentaac918473dab5c241575ef1faf6f91a1736df61d (diff)
downloadports-687591dd75e7bc33dfeb597493d97e5baaf89f1d.tar.gz
ports-687591dd75e7bc33dfeb597493d97e5baaf89f1d.zip
Notes
Diffstat (limited to 'archivers/php72-zlib')
-rw-r--r--archivers/php72-zlib/Makefile9
-rw-r--r--archivers/php72-zlib/files/patch-zlib.c10
2 files changed, 19 insertions, 0 deletions
diff --git a/archivers/php72-zlib/Makefile b/archivers/php72-zlib/Makefile
new file mode 100644
index 000000000000..65f534fc0c81
--- /dev/null
+++ b/archivers/php72-zlib/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php72-zlib/files/patch-zlib.c b/archivers/php72-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..be02c50d1df6
--- /dev/null
+++ b/archivers/php72-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2016-06-21 19:57:08 UTC
++++ zlib.c
+@@ -1480,6 +1480,7 @@ static PHP_MSHUTDOWN_FUNCTION(zlib)
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+ if (!ZLIBG(handler_registered)) {
+ ZLIBG(output_compression) = ZLIBG(output_compression_default);