aboutsummaryrefslogtreecommitdiff
path: root/archivers/pigz
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2023-08-20 06:25:50 +0000
committerXin LI <delphij@FreeBSD.org>2023-08-20 06:25:50 +0000
commitff2ab3e6aca607c768d935bb98ca05de467ac14c (patch)
tree9d91e01b54b086c45fc7f1147bd3c7a1e90c0a12 /archivers/pigz
parent41460e62d0e938b82531f093acb30e351372f507 (diff)
downloadports-ff2ab3e6aca607c768d935bb98ca05de467ac14c.tar.gz
ports-ff2ab3e6aca607c768d935bb98ca05de467ac14c.zip
Diffstat (limited to 'archivers/pigz')
-rw-r--r--archivers/pigz/Makefile2
-rw-r--r--archivers/pigz/distinfo6
-rw-r--r--archivers/pigz/files/patch-pigz.c45
3 files changed, 4 insertions, 49 deletions
diff --git a/archivers/pigz/Makefile b/archivers/pigz/Makefile
index f99ea34a075a..aa2f0c91e0de 100644
--- a/archivers/pigz/Makefile
+++ b/archivers/pigz/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pigz
-PORTVERSION= 2.7
+PORTVERSION= 2.8
CATEGORIES= archivers
MASTER_SITES= http://www.zlib.net/pigz/ \
http://freebsd.unixfreunde.de/sources/
diff --git a/archivers/pigz/distinfo b/archivers/pigz/distinfo
index 7088bee9bb43..30eaeef4a98a 100644
--- a/archivers/pigz/distinfo
+++ b/archivers/pigz/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642392318
-SHA256 (pigz-2.7.tar.gz) = b4c9e60344a08d5db37ca7ad00a5b2c76ccb9556354b722d56d55ca7e8b1c707
-SIZE (pigz-2.7.tar.gz) = 108102
+TIMESTAMP = 1692512490
+SHA256 (pigz-2.8.tar.gz) = eb872b4f0e1f0ebe59c9f7bd8c506c4204893ba6a8492de31df416f0d5170fd0
+SIZE (pigz-2.8.tar.gz) = 121304
diff --git a/archivers/pigz/files/patch-pigz.c b/archivers/pigz/files/patch-pigz.c
deleted file mode 100644
index 72fe98af1c5f..000000000000
--- a/archivers/pigz/files/patch-pigz.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- pigz.c.orig 2022-01-17 19:06:15 UTC
-+++ pigz.c
-@@ -558,9 +558,7 @@ local struct {
- int procs; // maximum number of compression threads (>= 1)
- int setdict; // true to initialize dictionary in each thread
- size_t block; // uncompressed input size per thread (>= 32K)
--#ifndef NOTHREAD
- crc_t shift; // pre-calculated CRC-32 shift for length block
--#endif
-
- // saved gzip/zip header data for decompression, testing, and listing
- time_t stamp; // time stamp from gzip header
-@@ -1338,9 +1336,6 @@ local long zlib_vernum(void) {
- return left < 2 ? num << (left << 2) : -1;
- }
-
--#ifndef NOTHREAD
--// -- threaded portions of pigz --
--
- // -- check value combination routines for parallel calculation --
-
- #define COMB(a,b,c) (g.form == 1 ? adler32_comb(a,b,c) : crc32_comb(a,b,c))
-@@ -1421,6 +1416,9 @@ local unsigned long adler32_comb(unsigned long adler1,
- return sum1 | (sum2 << 16);
- }
-
-+#ifndef NOTHREAD
-+// -- threaded portions of pigz --
-+
- // -- pool of spaces for buffer management --
-
- // These routines manage a pool of spaces. Each pool specifies a fixed size
-@@ -4337,11 +4335,11 @@ local void defaults(void) {
- ZopfliInitOptions(&g.zopts);
- #endif
- g.block = 131072UL; // 128K
-+ g.shift = x2nmodp(g.block, 3);
- #ifdef NOTHREAD
- g.procs = 1;
- #else
- g.procs = nprocs(8);
-- g.shift = x2nmodp(g.block, 3);
- #endif
- g.rsync = 0; // don't do rsync blocking
- g.setdict = 1; // initialize dictionary each thread