aboutsummaryrefslogtreecommitdiff
path: root/archivers/ppmd/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-29 16:32:05 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-29 16:32:05 +0000
commit2415ce21efd1698a5d480cecb9d9dcde1e825d65 (patch)
tree364891c0a06c27a496480ac197b052bb2e3abbdb /archivers/ppmd/Makefile
parent090b82c080886c9564582a1a6378435e9fae70e5 (diff)
Add ppmd 20050811, a fast archiver with a good compression ratio.
PR: ports/84796 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=141352
Diffstat (limited to 'archivers/ppmd/Makefile')
-rw-r--r--archivers/ppmd/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/archivers/ppmd/Makefile b/archivers/ppmd/Makefile
new file mode 100644
index 000000000000..ab334fb894fa
--- /dev/null
+++ b/archivers/ppmd/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ppmd
+# Date created: 11 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ppmd
+PORTVERSION= 20050811
+CATEGORIES= archivers
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A fast archiver with a good compression ratio
+
+MAN1= ppmd.1
+PORTDOCS= read_me.txt
+PLIST_FILES= bin/ppmd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>