aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-liblzma
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-15 20:09:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-15 20:09:41 +0000
commit0af29caee89a7fd5e71e8d22229a5c63abea7251 (patch)
treebfe67d606a357b5b163650fb01f01dce6d9072c8 /archivers/py-liblzma
parentaf485f02e877f0f95b8bdacb9cfbf73640c23b13 (diff)
Python module implementing LZMA Utils' liblzma API
PylibLZMA provides a python interface for the liblzma library to read and write data that has been compressed or can be decompressed by Lasse Collin's LZMA Utils. WWW: http://launchpad.net/pyliblzma PR: ports/129560 Submitted by: David Naylor <dragonsa at highveldmail.co.za>
Notes
Notes: svn path=/head/; revision=228452
Diffstat (limited to 'archivers/py-liblzma')
-rw-r--r--archivers/py-liblzma/Makefile25
-rw-r--r--archivers/py-liblzma/distinfo3
-rw-r--r--archivers/py-liblzma/files/patch-setup.py19
-rw-r--r--archivers/py-liblzma/pkg-descr7
-rw-r--r--archivers/py-liblzma/pkg-plist4
5 files changed, 58 insertions, 0 deletions
diff --git a/archivers/py-liblzma/Makefile b/archivers/py-liblzma/Makefile
new file mode 100644
index 000000000000..5b875319c3b1
--- /dev/null
+++ b/archivers/py-liblzma/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-liblzma
+# Date created: 09 Dec 2008
+# Whom: David Naylor <dragonsa@highveldmail.co.za>
+#
+# $FreeBSD$
+
+PORTNAME= liblzma
+PORTVERSION= 0.5.1
+CATEGORIES= archivers python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}source/p/pyliblzma/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYDISTUTILS_PKGNAME}-${PORTVERSION}
+
+MAINTAINER= dragonsa@highveldmail.co.za
+COMMENT= Python binding for the LZMA compression library
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS= lzma.0:${PORTSDIR}/archivers/lzmautils-devel
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= py${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/archivers/py-liblzma/distinfo b/archivers/py-liblzma/distinfo
new file mode 100644
index 000000000000..aabc385f71f0
--- /dev/null
+++ b/archivers/py-liblzma/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyliblzma-0.5.1.tar.bz2) = e3e3f1d5e29f9cf47c37efa6489d5273
+SHA256 (pyliblzma-0.5.1.tar.bz2) = 341e44901fc307f36b77e42684b769420c613155400b877101b5a8d25c5296df
+SIZE (pyliblzma-0.5.1.tar.bz2) = 48521
diff --git a/archivers/py-liblzma/files/patch-setup.py b/archivers/py-liblzma/files/patch-setup.py
new file mode 100644
index 000000000000..c1aaeaa42194
--- /dev/null
+++ b/archivers/py-liblzma/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py~ 2009-01-12 14:38:38.000000000 +0200
++++ setup.py 2009-01-12 15:03:21.000000000 +0200
+@@ -23,7 +23,7 @@
+ #
+ import sys, os
+ from warnings import warn
+-from setuptools import setup, Extension
++from distutils.core import setup, Extension
+
+ descr = "Python bindings for liblzma"
+ long_descr = """PylibLZMA provides a python interface for the liblzma library
+@@ -74,7 +74,6 @@
+ ],
+ py_modules = modules,
+ ext_modules = extens,
+- test_suite = 'tests',
+ )
+
+ sys.exit(0)
diff --git a/archivers/py-liblzma/pkg-descr b/archivers/py-liblzma/pkg-descr
new file mode 100644
index 000000000000..212ac2f28606
--- /dev/null
+++ b/archivers/py-liblzma/pkg-descr
@@ -0,0 +1,7 @@
+Python module implementing LZMA Utils' liblzma API
+
+PylibLZMA provides a python interface for the liblzma
+library to read and write data that has been compressed
+or can be decompressed by Lasse Collin's LZMA Utils.
+
+WWW: http://launchpad.net/pyliblzma
diff --git a/archivers/py-liblzma/pkg-plist b/archivers/py-liblzma/pkg-plist
new file mode 100644
index 000000000000..c6e95efc3b9d
--- /dev/null
+++ b/archivers/py-liblzma/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/liblzma.py
+%%PYTHON_SITELIBDIR%%/lzma.so
+%%PYTHON_SITELIBDIR%%/liblzma.pyc
+%%PYTHON_SITELIBDIR%%/liblzma.pyo