aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm4/Makefile
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2018-09-04 13:35:09 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2018-09-04 13:35:09 +0000
commit9d7d51b4f3396b36b4ceedeeabe0d158663a6bd5 (patch)
treeb4452e9f537b9951f946db73b867206554eded3e /archivers/rpm4/Makefile
parent6db9d2a6a75dace223f51e2ef6606d451230903c (diff)
downloadports-9d7d51b4f3396b36b4ceedeeabe0d158663a6bd5.tar.gz
ports-9d7d51b4f3396b36b4ceedeeabe0d158663a6bd5.zip
Notes
Diffstat (limited to 'archivers/rpm4/Makefile')
-rw-r--r--archivers/rpm4/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index e872baa38c91..4fcd7459856c 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rpm
PORTVERSION= 4.14.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://ftp.rpm.org/releases/rpm-${PORTVERSION:R}.x/
PKGNAMESUFFIX= 4
@@ -16,6 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpopt.so:devel/popt \
libnss3.so:security/nss
+RUN_DEPENDS= bash:shells/bash
USES= alias bdb gmake libarchive libtool lua:51 pathfix pkgconfig \
shebangfix tar:bzip2
@@ -27,6 +28,7 @@ SHEBANG_FILES= scripts/brp-python-bytecompile scripts/check-prereqs \
scripts/mono-find-requires scripts/mono-find-provides \
scripts/pkgconfigdeps.sh scripts/fontconfig.prov \
scripts/rpmdb_loadcvt scripts/perl.prov scripts/perl.req \
+ scripts/pythondistdeps.py scripts/find-lang.sh \
python/rpm/transaction.py
CONFIGURE_ARGS= --with-external-db \
--without-db \
@@ -72,6 +74,9 @@ post-patch:
@${REINPLACE_CMD} -e 's/ __GLIBC__.*/& || defined(__FreeBSD__)/' \
${WRKSRC}/system.h
+post-install-PYTHON-off:
+ @${RM} ${STAGEDIR}${PREFIX}/lib/rpm/pythondistdeps.py
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} librpm/html ${STAGEDIR}${DOCSDIR}