aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm4
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-07-06 16:47:50 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-07-06 16:47:50 +0000
commit6ab8c72d0145c4cb1a2e955f2c92cd22aff859a5 (patch)
tree72c55d0396152e9a73699ab1a7e33c4b3c818c9c /archivers/rpm4
parent28badd9f9d7777605f5128f1d4b6d284b4ec950f (diff)
Notes
Diffstat (limited to 'archivers/rpm4')
-rw-r--r--archivers/rpm4/Makefile3
-rw-r--r--archivers/rpm4/files/extra-patch-lib_fs.c11
2 files changed, 14 insertions, 0 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index acb2af54c2ae..479104e5d1f8 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -81,6 +81,9 @@ PORTDOCS= *
.if ${OSVERSION} < 800502
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rpmio_rpmsq.c
.endif
+.if ${OSVERSION} < 700000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-lib_fs.c
+.endif
post-patch:
${REINPLACE_CMD} -e '/^pkgconfigdir/s:/:data/:' \
diff --git a/archivers/rpm4/files/extra-patch-lib_fs.c b/archivers/rpm4/files/extra-patch-lib_fs.c
new file mode 100644
index 000000000000..810cc5448ebe
--- /dev/null
+++ b/archivers/rpm4/files/extra-patch-lib_fs.c
@@ -0,0 +1,11 @@
+--- lib/fs.c.orig 2010-07-06 07:27:10.000000000 +0200
++++ lib/fs.c 2010-07-06 07:27:12.000000000 +0200
+@@ -134,6 +134,8 @@ exit:
+
+ #else /* HAVE_MNTCTL */
+
++#include <sys/mount.h>
++
+ /**
+ * Get information for mounted file systems.
+ * @todo determine rdonly for non-linux file systems.