aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm4
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2015-03-22 18:40:54 +0000
committerJohan van Selst <johans@FreeBSD.org>2015-03-22 18:40:54 +0000
commit7abac1dbfe319ec0a4191c4800b6e033c35b78da (patch)
tree87d6ad14ed38ebc16232e8d508f3bd777db74fce /archivers/rpm4
parentddb749dd646e75355ce14f5b153d2d442f462554 (diff)
Notes
Diffstat (limited to 'archivers/rpm4')
-rw-r--r--archivers/rpm4/Makefile2
-rw-r--r--archivers/rpm4/files/patch-lib_cpio.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 62253f15bd29..f20e12495a53 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rpm
PORTVERSION= 4.12.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://rpm.org/releases/rpm-${PORTVERSION:R:R}.x/ \
ftp://ftp.mirrorservice.org/sites/ftp.rpm.org/pub/rpm/dist/rpm-${PORTVERSION:E}.x/
diff --git a/archivers/rpm4/files/patch-lib_cpio.c b/archivers/rpm4/files/patch-lib_cpio.c
new file mode 100644
index 000000000000..a06895394295
--- /dev/null
+++ b/archivers/rpm4/files/patch-lib_cpio.c
@@ -0,0 +1,15 @@
+Fix for CVE-2014-8118 as found at
+https://bugzilla.redhat.com/show_bug.cgi?id=1168715
+
+--- lib/cpio.c.orig 2015-03-22 19:29:29.000000000 +0100
++++ lib/cpio.c 2015-03-22 19:29:30.000000000 +0100
+@@ -399,6 +399,9 @@ int rpmcpioHeaderRead(rpmcpio_t cpio, ch
+
+ GET_NUM_FIELD(hdr.filesize, fsize);
+ GET_NUM_FIELD(hdr.namesize, nameSize);
++ if (nameSize <= 0 || nameSize > 4096) {
++ return RPMERR_BAD_HEADER;
++ }
+
+ char name[nameSize + 1];
+ read = Fread(name, nameSize, 1, cpio->fd);