aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm5/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-03-05 02:26:10 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-03-05 02:26:10 +0000
commit63157dad83243393adff5843084d51e9b03574ab (patch)
tree89a8a823f2ae4f14430507b26c99df9d0ca601ad /archivers/rpm5/Makefile
parent6a093bc2328d1012ddb409cc8be081631c8438eb (diff)
Notes
Diffstat (limited to 'archivers/rpm5/Makefile')
-rw-r--r--archivers/rpm5/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
new file mode 100644
index 000000000000..2c6ca5877949
--- /dev/null
+++ b/archivers/rpm5/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: rpm
+# Date created: 6 May 2003
+# Whom: Greg Lewis <glewis@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= rpm
+PORTVERSION= 4.0.4
+CATEGORIES= archivers
+MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/
+MASTER_SITE_SUBDIR= rpm-4.0.x
+
+MAINTAINER= glewis@FreeBSD.org
+COMMENT= The RPM Package Manager
+
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3 \
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ popt.0:${PORTSDIR}/devel/popt
+BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
+
+USE_LIBTOOL_VER=14
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+LATEST_LINK= rpm4
+CONFLICTS= beecrypt-* rpm-3.* rpm2cpio-*
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+=--with-python=auto
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+CPPFLAGS+= -I${PYTHON_INCLUDEDIR}
+LDFLAGS+= -L${PYTHON_LIBDIR}
+.else
+CONFIGURE_ARGS+=--without-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+=--without-db
+CONFIGURE_ARGS+=--with-popt-prefix="${LOCALBASE}"
+CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
+
+MAN1= gendiff.1
+MAN8= rpm.8 rpm2cpio.8 rpmbuild.8
+
+post-patch:
+ ${REINPLACE_CMD} -e 's:%%LOCALBASE%%:${LOCALBASE}:' \
+ ${WRKSRC}/configure ${WRKSRC}/beecrypt/configure
+
+post-install:
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>