aboutsummaryrefslogtreecommitdiff
path: root/archivers/ruby-lha/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-01-09 20:19:01 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-01-09 20:19:01 +0000
commit822938a31c12e8302d9d170b535970ae8ba60247 (patch)
tree10ee834ae62ed24e366b7cad03e94924db643223 /archivers/ruby-lha/Makefile
parent168e68a284643b47ab33226fa56ba8ca9e2f67a9 (diff)
downloadports-822938a31c12e8302d9d170b535970ae8ba60247.tar.gz
ports-822938a31c12e8302d9d170b535970ae8ba60247.zip
Notes
Diffstat (limited to 'archivers/ruby-lha/Makefile')
-rw-r--r--archivers/ruby-lha/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/archivers/ruby-lha/Makefile b/archivers/ruby-lha/Makefile
new file mode 100644
index 000000000000..1f630aac5935
--- /dev/null
+++ b/archivers/ruby-lha/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ruby-lha
+# Date created: 09 January 2006
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= lha
+PORTVERSION= 0.8.1
+CATEGORIES= archivers ruby
+MASTER_SITES= http://arton.no-ip.info/data/lhalib/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= lhalib-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A Ruby extension to unpack lha-compressed files
+
+USE_ZIP= yes
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+RUBY_EXTCONF= ext/extconf.rb
+
+CONFIGURE_ARGS= --rubyprog=${RUBY}
+
+EXAMPLES= test/test.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}/
+ @${INSTALL_SCRIPT} ${EXAMPLES:S,^,${WRKSRC}/,} ${RUBY_MODEXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>