aboutsummaryrefslogtreecommitdiff
path: root/archivers/rvm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-29 23:20:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-29 23:20:45 +0000
commit5c7460ca6b0bc8097ddbdd580c14072a86f97733 (patch)
treeababb570dfc349a0c95445062973780ee503c43e /archivers/rvm
parent674b84bcd9a9c9c5da092990588c4b231160243b (diff)
downloadports-5c7460ca6b0bc8097ddbdd580c14072a86f97733.tar.gz
ports-5c7460ca6b0bc8097ddbdd580c14072a86f97733.zip
Notes
Diffstat (limited to 'archivers/rvm')
-rw-r--r--archivers/rvm/Makefile2
-rw-r--r--archivers/rvm/files/patch-configure107
2 files changed, 107 insertions, 2 deletions
diff --git a/archivers/rvm/Makefile b/archivers/rvm/Makefile
index ad063c94a22f..cd3f172c1290 100644
--- a/archivers/rvm/Makefile
+++ b/archivers/rvm/Makefile
@@ -19,8 +19,6 @@ COMMENT= An archive manager that uses rsync to manage backups
BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= "Configure script attempts to allocate an infinite amount of memory to see what happens when it runs out"
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_LATEST_LINK= yes
diff --git a/archivers/rvm/files/patch-configure b/archivers/rvm/files/patch-configure
new file mode 100644
index 000000000000..0ded3b7ee30f
--- /dev/null
+++ b/archivers/rvm/files/patch-configure
@@ -0,0 +1,107 @@
+--- configure.orig Mon Nov 14 19:34:54 2005
++++ configure Sun Jan 29 16:34:06 2006
+@@ -8613,104 +8613,9 @@
+
+ fi
+
+-
+-
+-echo "$as_me:$LINENO: checking if the stl throws an exception at memory allocation failure" >&5
+-echo $ECHO_N "checking if the stl throws an exception at memory allocation failure... $ECHO_C" >&6
+-if test "${ac_cv_cxx_exception_on_failed_alloc+set}" = set; then
+- echo "$as_me:$LINENO: result: (cached) $ac_cv_cxx_exception_on_failed_alloc" >&5
+-echo "${ECHO_T}(cached) $ac_cv_cxx_exception_on_failed_alloc" >&6
+-else
+- if test "$cross_compiling" = yes; then
+- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
+-else
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-#include <string>
+-#include <exception>
+-
+-int main(int argc, char **argv)
+-{
+- std::string str;
+-
+- str = "a";
+- while (true) {
+- try {
+- str += str;
+- }
+- catch(...) {
+- return(0);
+- }
+- }
+- return(0);
+-}
+-
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+- ac_cv_cxx_exception_on_failed_alloc=yes
+-
+-else
+- echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-( exit $ac_status )
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+- ac_cv_cxx_exception_on_failed_alloc=no
+-
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
+-fi
+-if test $ac_cv_cxx_exception_on_failed_alloc = yes; then
+-
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_EXCEPTION_ON_ALLOC_FAILURE 1
+ _ACEOF
+-
+-else
+- { echo "$as_me:$LINENO: WARNING:
+-
+-*** NOTICE: This implementation of the STL does not throw an exception for
+-memory allocation failure. (This feature is known to be lacking in at least
+-some pre 3.x versions of the gcc compiler suite.) Memory allocation failure
+-should not mean program termination, but without this feature in the STL, the
+-author of this software package cannot guarentee the ability to handle memory
+-allocation failure gracefully.
+-
+- " >&5
+-echo "$as_me: WARNING:
+-
+-*** NOTICE: This implementation of the STL does not throw an exception for
+-memory allocation failure. (This feature is known to be lacking in at least
+-some pre 3.x versions of the gcc compiler suite.) Memory allocation failure
+-should not mean program termination, but without this feature in the STL, the
+-author of this software package cannot guarentee the ability to handle memory
+-allocation failure gracefully.
+-
+- " >&2;}
+-fi
+
+ # Extract the first word of "rsync", so it can be a program name with args.
+ set dummy rsync; ac_word=$2