aboutsummaryrefslogtreecommitdiff
path: root/archivers/sharutils
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-22 02:12:54 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-22 02:12:54 +0000
commit09bd84b0f3fae9f179f2d67bcbdce1b6d699d389 (patch)
treec7ef0f3cc26c325a0707e4f2c125756a01e3397c /archivers/sharutils
parent5dc6fc457f3df6d6cae2423033750d231be00637 (diff)
downloadports-09bd84b0f3fae9f179f2d67bcbdce1b6d699d389.tar.gz
ports-09bd84b0f3fae9f179f2d67bcbdce1b6d699d389.zip
Notes
Diffstat (limited to 'archivers/sharutils')
-rw-r--r--archivers/sharutils/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/archivers/sharutils/Makefile b/archivers/sharutils/Makefile
index d2ef4d1a5a45..3b8a775921ea 100644
--- a/archivers/sharutils/Makefile
+++ b/archivers/sharutils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sharutils
PORTVERSION= 4.3.77
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -14,6 +15,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= sylvioc@gmail.com
COMMENT= Pack, send and unpack shell archives; synchronize via e-mail
+USE_PERL5= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g --disable-uucode
INSTALL_TARGET= install install-man
@@ -31,4 +34,9 @@ PLIST_FILES+= share/locale/${l}/LC_MESSAGES/sharutils.mo
.endfor
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|@SH@|${SH}|' \
+ ${WRKSRC}/src/mail-files.in ${WRKSRC}/src/mailshar.in
+ @${REINPLACE_CMD} -e 's|@PERL@|${PERL}|' ${WRKSRC}/src/remsync.in
+
.include <bsd.port.mk>