aboutsummaryrefslogtreecommitdiff
path: root/archivers/squsq/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-08-04 14:41:49 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-08-04 14:41:49 +0000
commita7c936217a8dd41b07a0c4959709550a76a3bc0b (patch)
tree67b565b7173d81f398439052b2da4a419e145f94 /archivers/squsq/Makefile
parent34a999626be1cba703c33f07a4df5589085fd4cf (diff)
downloadports-a7c936217a8dd41b07a0c4959709550a76a3bc0b.tar.gz
ports-a7c936217a8dd41b07a0c4959709550a76a3bc0b.zip
Notes
Diffstat (limited to 'archivers/squsq/Makefile')
-rw-r--r--archivers/squsq/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/archivers/squsq/Makefile b/archivers/squsq/Makefile
index 5e589039d1a5..aa1fe233d287 100644
--- a/archivers/squsq/Makefile
+++ b/archivers/squsq/Makefile
@@ -4,22 +4,27 @@
PORTNAME= squsq
PORTVERSION= 3.3
CATEGORIES= archivers
-MASTER_SITES= http://freebsd.nsu.ru/distfiles/ NETBSD
+MASTER_SITES= http://freebsd.nsu.ru/distfiles/ NETBSD LOCAL/danfe
DISTNAME= t20-squsq-3.3
MAINTAINER= ports@FreeBSD.org
COMMENT= Compressor/decompressor for CP/M "Squeeze" compressed files
-BROKEN= unfetchable
-
CONFLICTS= squirrel-[0-9]*
WRKSRC= ${WRKDIR}/t20-squsq
MAKEFILE= ${FILESDIR}/Makefile
CFLAGS+= -Wno-error=return-type
PLIST_FILES= bin/sq bin/usq
+PORTDOCS= readme
+
+OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sq ${WRKSRC}/usq ${STAGEDIR}${PREFIX}/bin
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>