aboutsummaryrefslogtreecommitdiff
path: root/archivers/stuffit/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 03:29:43 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 03:29:43 +0000
commit207a3f7efeac62a79711f8804451212ca06a1ac9 (patch)
treedf932cd5a4cc09a2c4e415919009cbe32fa4f7d8 /archivers/stuffit/Makefile
parentebe3e0a16369964c39611382fd6b7ed62eed4ae2 (diff)
downloadports-207a3f7efeac62a79711f8804451212ca06a1ac9.tar.gz
ports-207a3f7efeac62a79711f8804451212ca06a1ac9.zip
Notes
Diffstat (limited to 'archivers/stuffit/Makefile')
-rw-r--r--archivers/stuffit/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/archivers/stuffit/Makefile b/archivers/stuffit/Makefile
new file mode 100644
index 000000000000..d53d5101390e
--- /dev/null
+++ b/archivers/stuffit/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: stuffit
+# Date created: 12 Dec 2001
+# Whom: Nathan Ahlstrom <nra@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stuffit
+PORTVERSION= 5.2.0.611
+CATEGORIES= archivers linux
+MASTER_SITES= ftp://ftp.aladdinsys.com/pub/linux/StuffIt_for_Linux/ \
+ ftp://ftp2.aladdinsys.com/pub/linux/StuffIt_for_Linux/
+DISTNAME= stuffit520.611linux-i386
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= \
+ ${LINUXBASE}/lib/libc-2.2.2.so:${PORTSDIR}/emulators/linux_base-7
+
+#USE_LINUX= yes
+
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+NO_CDROM= Shareware -- should not redistribute
+NO_PACKAGE= Only unmodified original package can be distributed
+STRIP= # empty: do not strip linux binary during INSTALL_PROGRAM
+WRKSRC= ${WRKDIR}
+
+STUFFIT_FILES= bin/unstuff bin/stuff
+STUFFIT_MAN= man/man1/stuff.1 man/man1/unstuff.1
+
+post-fetch:
+ @${CHMOD} a+x ${DISTDIR}/${DISTFILES}
+
+do-install:
+.for sFile in ${STUFFIT_FILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${sFile} ${PREFIX}/bin
+ brandelf -t Linux ${PREFIX}/${sFile}
+.endfor
+.for mFile in ${STUFFIT_MAN}
+ ${INSTALL_MAN} ${WRKSRC}/${mFile} ${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>