aboutsummaryrefslogtreecommitdiff
path: root/archivers/tardy/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-04 09:03:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-04 09:03:11 +0000
commit14d9afe0876877fe8b904e1b1658763ddad8b6a5 (patch)
tree9887e56e83883fc25c5a684af1008bf71352ddd5 /archivers/tardy/Makefile
parentbfcdbb1f5edefdf6ef6f009d46c24a6fa79c331e (diff)
downloadports-14d9afe0876877fe8b904e1b1658763ddad8b6a5.tar.gz
ports-14d9afe0876877fe8b904e1b1658763ddad8b6a5.zip
Notes
Diffstat (limited to 'archivers/tardy/Makefile')
-rw-r--r--archivers/tardy/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index ef75b39f39d2..7238752326de 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -6,17 +6,26 @@
#
PORTNAME= tardy
-PORTVERSION= 1.20
+PORTVERSION= 1.24
CATEGORIES= archivers
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/files/${PORTVERSION}/ CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Manipulate the file headers in tar archive files in various ways
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/include/libiberty/libiberty.h:${PORTSDIR}/devel/gnulibiberty
+LIB_DEPENDS= explain.45:${PORTSDIR}/devel/libexplain
+
GNU_CONFIGURE= yes
+
MAKE_JOBS_UNSAFE= yes
-LICENSE= GPLv3
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
MAN1= tardy.1
PLIST_FILES= bin/tardy
@@ -28,6 +37,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man1/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
.include <bsd.port.mk>