aboutsummaryrefslogtreecommitdiff
path: root/archivers/tardy
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-11-10 19:18:24 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-11-10 19:18:24 +0000
commit77a60a24f4eb76f2e0b3e584df0700a07eecba7b (patch)
tree1a9ba72de01b0949f0b19a480a298d658b0b5042 /archivers/tardy
parentf2b3eda329f891dec7ffbd85c11b7c28feb77531 (diff)
downloadports-77a60a24f4eb76f2e0b3e584df0700a07eecba7b.tar.gz
ports-77a60a24f4eb76f2e0b3e584df0700a07eecba7b.zip
Notes
Diffstat (limited to 'archivers/tardy')
-rw-r--r--archivers/tardy/Makefile10
-rw-r--r--archivers/tardy/distinfo4
-rw-r--r--archivers/tardy/files/patch-libtardy__rcstring__list__sort_vers.cc11
-rw-r--r--archivers/tardy/files/patch-libtardy__rcstring__list__strverscmp.h160
-rw-r--r--archivers/tardy/files/patch-tardy__tardy.h11
5 files changed, 15 insertions, 181 deletions
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index 21df49f789ba..7f300abe4429 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tardy
-PORTVERSION= 1.24
+PORTVERSION= 1.25
CATEGORIES= archivers
MASTER_SITES= CRITICAL
@@ -39,10 +39,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "i386" || ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not link
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/tardy/distinfo b/archivers/tardy/distinfo
index 926c8e6a7beb..6176296f4a9b 100644
--- a/archivers/tardy/distinfo
+++ b/archivers/tardy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tardy-1.24.tar.gz) = b0eb792f33284078ee841e2747bfa48c261a8d1ede5b842a61dbf82a6f3c0cd9
-SIZE (tardy-1.24.tar.gz) = 1831193
+SHA256 (tardy-1.25.tar.gz) = 8ae113b1d10d7e645f1f6a4ebf2bc31b37cae7871b057a275aa787288ce60bb0
+SIZE (tardy-1.25.tar.gz) = 1834343
diff --git a/archivers/tardy/files/patch-libtardy__rcstring__list__sort_vers.cc b/archivers/tardy/files/patch-libtardy__rcstring__list__sort_vers.cc
deleted file mode 100644
index 3abd005e1a3c..000000000000
--- a/archivers/tardy/files/patch-libtardy__rcstring__list__sort_vers.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libtardy/rcstring/list/sort_vers.cc.orig 2011-10-03 14:12:58.000000000 +0200
-+++ ./libtardy/rcstring/list/sort_vers.cc 2011-10-04 10:09:13.000000000 +0200
-@@ -21,6 +21,8 @@
-
- #include <libtardy/rcstring/list.h>
-
-+#include "strverscmp.h"
-+
-
- static int
- cmp(const void *va, const void *vb)
diff --git a/archivers/tardy/files/patch-libtardy__rcstring__list__strverscmp.h b/archivers/tardy/files/patch-libtardy__rcstring__list__strverscmp.h
deleted file mode 100644
index 4e15b8b6cd56..000000000000
--- a/archivers/tardy/files/patch-libtardy__rcstring__list__strverscmp.h
+++ /dev/null
@@ -1,160 +0,0 @@
---- ./libtardy/rcstring/list/strverscmp.h.orig 2011-10-04 10:09:13.000000000 +0200
-+++ ./libtardy/rcstring/list/strverscmp.h 2011-10-04 10:11:40.000000000 +0200
-@@ -0,0 +1,157 @@
-+/* Compare strings while treating digits characters numerically.
-+ Copyright (C) 1997, 2002, 2005 Free Software Foundation, Inc.
-+ This file is part of the libiberty library.
-+ Contributed by Jean-François Bignolles <bignolle@ecoledoc.ibp.fr>, 1997.
-+
-+ Libiberty is free software; you can redistribute it and/or
-+ modify it under the terms of the GNU Lesser General Public
-+ License as published by the Free Software Foundation; either
-+ version 2.1 of the License, or (at your option) any later version.
-+
-+ Libiberty is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ Lesser General Public License for more details.
-+
-+ You should have received a copy of the GNU Lesser General Public
-+ License along with the GNU C Library; if not, write to the Free
-+ Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-+ 02110-1301 USA. */
-+
-+#include <libiberty/libiberty.h>
-+#include <libiberty/safe-ctype.h>
-+
-+/*
-+@deftypefun int strverscmp (const char *@var{s1}, const char *@var{s2})
-+The @code{strverscmp} function compares the string @var{s1} against
-+@var{s2}, considering them as holding indices/version numbers. Return
-+value follows the same conventions as found in the @code{strverscmp}
-+function. In fact, if @var{s1} and @var{s2} contain no digits,
-+@code{strverscmp} behaves like @code{strcmp}.
-+
-+Basically, we compare strings normally (character by character), until
-+we find a digit in each string - then we enter a special comparison
-+mode, where each sequence of digits is taken as a whole. If we reach the
-+end of these two parts without noticing a difference, we return to the
-+standard comparison mode. There are two types of numeric parts:
-+"integral" and "fractional" (those begin with a '0'). The types
-+of the numeric parts affect the way we sort them:
-+
-+@itemize @bullet
-+@item
-+integral/integral: we compare values as you would expect.
-+
-+@item
-+fractional/integral: the fractional part is less than the integral one.
-+Again, no surprise.
-+
-+@item
-+fractional/fractional: the things become a bit more complex.
-+If the common prefix contains only leading zeroes, the longest part is less
-+than the other one; else the comparison behaves normally.
-+@end itemize
-+
-+@smallexample
-+strverscmp ("no digit", "no digit")
-+ @result{} 0 // @r{same behavior as strcmp.}
-+strverscmp ("item#99", "item#100")
-+ @result{} <0 // @r{same prefix, but 99 < 100.}
-+strverscmp ("alpha1", "alpha001")
-+ @result{} >0 // @r{fractional part inferior to integral one.}
-+strverscmp ("part1_f012", "part1_f01")
-+ @result{} >0 // @r{two fractional parts.}
-+strverscmp ("foo.009", "foo.0")
-+ @result{} <0 // @r{idem, but with leading zeroes only.}
-+@end smallexample
-+
-+This function is especially useful when dealing with filename sorting,
-+because filenames frequently hold indices/version numbers.
-+@end deftypefun
-+
-+*/
-+
-+/* states: S_N: normal, S_I: comparing integral part, S_F: comparing
-+ fractional parts, S_Z: idem but with leading Zeroes only */
-+#define S_N 0x0
-+#define S_I 0x4
-+#define S_F 0x8
-+#define S_Z 0xC
-+
-+/* result_type: CMP: return diff; LEN: compare using len_diff/diff */
-+#define CMP 2
-+#define LEN 3
-+
-+
-+/* Compare S1 and S2 as strings holding indices/version numbers,
-+ returning less than, equal to or greater than zero if S1 is less than,
-+ equal to or greater than S2 (for more info, see the Glibc texinfo doc). */
-+
-+int
-+strverscmp (const char *s1, const char *s2)
-+{
-+ const unsigned char *p1 = (const unsigned char *) s1;
-+ const unsigned char *p2 = (const unsigned char *) s2;
-+ unsigned char c1, c2;
-+ int state;
-+ int diff;
-+
-+ /* Symbol(s) 0 [1-9] others (padding)
-+ Transition (10) 0 (01) d (00) x (11) - */
-+ static const unsigned int next_state[] =
-+ {
-+ /* state x d 0 - */
-+ /* S_N */ S_N, S_I, S_Z, S_N,
-+ /* S_I */ S_N, S_I, S_I, S_I,
-+ /* S_F */ S_N, S_F, S_F, S_F,
-+ /* S_Z */ S_N, S_F, S_Z, S_Z
-+ };
-+
-+ static const int result_type[] =
-+ {
-+ /* state x/x x/d x/0 x/- d/x d/d d/0 d/-
-+ 0/x 0/d 0/0 0/- -/x -/d -/0 -/- */
-+
-+ /* S_N */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
-+ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
-+ /* S_I */ CMP, -1, -1, CMP, +1, LEN, LEN, CMP,
-+ +1, LEN, LEN, CMP, CMP, CMP, CMP, CMP,
-+ /* S_F */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
-+ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
-+ /* S_Z */ CMP, +1, +1, CMP, -1, CMP, CMP, CMP,
-+ -1, CMP, CMP, CMP
-+ };
-+
-+ if (p1 == p2)
-+ return 0;
-+
-+ c1 = *p1++;
-+ c2 = *p2++;
-+ /* Hint: '0' is a digit too. */
-+ state = S_N | ((c1 == '0') + (ISDIGIT (c1) != 0));
-+
-+ while ((diff = c1 - c2) == 0 && c1 != '\0')
-+ {
-+ state = next_state[state];
-+ c1 = *p1++;
-+ c2 = *p2++;
-+ state |= (c1 == '0') + (ISDIGIT (c1) != 0);
-+ }
-+
-+ state = result_type[state << 2 | (((c2 == '0') + (ISDIGIT (c2) != 0)))];
-+
-+ switch (state)
-+ {
-+ case CMP:
-+ return diff;
-+
-+ case LEN:
-+ while (ISDIGIT (*p1++))
-+ if (!ISDIGIT (*p2++))
-+ return 1;
-+
-+ return ISDIGIT (*p2) ? -1 : diff;
-+
-+ default:
-+ return state;
-+ }
-+}
diff --git a/archivers/tardy/files/patch-tardy__tardy.h b/archivers/tardy/files/patch-tardy__tardy.h
new file mode 100644
index 000000000000..7e3784bf20d4
--- /dev/null
+++ b/archivers/tardy/files/patch-tardy__tardy.h
@@ -0,0 +1,11 @@
+--- ./tardy/tardy.h.orig 2011-11-10 20:05:42.000000000 +0100
++++ ./tardy/tardy.h 2011-11-10 20:06:06.000000000 +0100
+@@ -38,7 +38,7 @@
+ void tardy_no_directories(void);
+ void tardy_no_fix_type(void);
+ void tardy_now(void);
+-void tardy_mtime(long when);
++void tardy_mtime(time_t when);
+ void tardy_prefix(const char *);
+ void tardy_remove_prefix(const char *);
+ void tardy_remove_prefix(long);