aboutsummaryrefslogtreecommitdiff
path: root/archivers/tardy
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-07-17 21:11:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-07-17 21:11:22 +0000
commitd92949bfe8b6ff419a6a07d712199b70b89b2f06 (patch)
treef0315661ffcf60d0606a0718a27897c50b81e41b /archivers/tardy
parentb122d597380a87076a8cf9abe566124b6b99e81e (diff)
downloadports-d92949bfe8b6ff419a6a07d712199b70b89b2f06.tar.gz
ports-d92949bfe8b6ff419a6a07d712199b70b89b2f06.zip
Notes
Diffstat (limited to 'archivers/tardy')
-rw-r--r--archivers/tardy/Makefile17
-rw-r--r--archivers/tardy/distinfo4
-rw-r--r--archivers/tardy/files/patch-tardy__tardy.h11
3 files changed, 15 insertions, 17 deletions
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index 7f300abe4429..44747fb2f9da 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= tardy
-PORTVERSION= 1.25
+PORTVERSION= 1.26
+DISTVERSIONSUFFIX= .D001
CATEGORIES= archivers
-MASTER_SITES= CRITICAL
+MASTER_SITES= SF/tardy/${PORTVERSION}/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Manipulate the file headers in tar archive files in various ways
@@ -17,7 +18,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/libiberty/libiberty.h:${PORTSDIR}/devel/gnulibiberty
-LIB_DEPENDS= explain.45:${PORTSDIR}/devel/libexplain
+LIB_DEPENDS= explain:${PORTSDIR}/devel/libexplain
GNU_CONFIGURE= yes
@@ -29,6 +30,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= tardy.1
PLIST_FILES= bin/tardy
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+BUILD_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+.endif
+
post-patch:
.for var in CFLAGS LDFLAGS
@${REINPLACE_CMD} -e 's|^\(${var}\)\ =\ \(.*\)|\1 ?= \2|' \
@@ -39,4 +48,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/archivers/tardy/distinfo b/archivers/tardy/distinfo
index 6176296f4a9b..a0f8a855bb16 100644
--- a/archivers/tardy/distinfo
+++ b/archivers/tardy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tardy-1.25.tar.gz) = 8ae113b1d10d7e645f1f6a4ebf2bc31b37cae7871b057a275aa787288ce60bb0
-SIZE (tardy-1.25.tar.gz) = 1834343
+SHA256 (tardy-1.26.D001.tar.gz) = 938ef85ba49bb4a2364b5f69495b75323d1753a7ec0c725a3ff7321910135bdc
+SIZE (tardy-1.26.D001.tar.gz) = 1843670
diff --git a/archivers/tardy/files/patch-tardy__tardy.h b/archivers/tardy/files/patch-tardy__tardy.h
deleted file mode 100644
index 7e3784bf20d4..000000000000
--- a/archivers/tardy/files/patch-tardy__tardy.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tardy/tardy.h.orig 2011-11-10 20:05:42.000000000 +0100
-+++ ./tardy/tardy.h 2011-11-10 20:06:06.000000000 +0100
-@@ -38,7 +38,7 @@
- void tardy_no_directories(void);
- void tardy_no_fix_type(void);
- void tardy_now(void);
--void tardy_mtime(long when);
-+void tardy_mtime(time_t when);
- void tardy_prefix(const char *);
- void tardy_remove_prefix(const char *);
- void tardy_remove_prefix(long);