aboutsummaryrefslogtreecommitdiff
path: root/archivers/unarj/Makefile
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-10-23 21:02:25 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-10-23 21:02:25 +0000
commit913bf1f75e8c807ccec6f3d381cf0ec8a7cf3d3e (patch)
tree942c0a08e9e020b9e4491233f2a94d2fc14fd88e /archivers/unarj/Makefile
parentb5ca2a054c3fdd6f82c1e804f47a1301efd4a4f0 (diff)
downloadports-913bf1f75e8c807ccec6f3d381cf0ec8a7cf3d3e.tar.gz
ports-913bf1f75e8c807ccec6f3d381cf0ec8a7cf3d3e.zip
Notes
Diffstat (limited to 'archivers/unarj/Makefile')
-rw-r--r--archivers/unarj/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/archivers/unarj/Makefile b/archivers/unarj/Makefile
index 9fcbf9660794..ef6ac256e05f 100644
--- a/archivers/unarj/Makefile
+++ b/archivers/unarj/Makefile
@@ -5,28 +5,22 @@ PORTNAME= unarj
PORTVERSION= 2.65
PORTREVISION= 2
CATEGORIES= archivers
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ache
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= ak-various-projects
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ak@FreeBSD.org
COMMENT= Allows files to be extracted from ARJ archives
-NO_STAGE= yes
PLIST_FILES= bin/unarj
PORTDOCS= unarj.txt technote.txt
-.include <bsd.port.options.mk>
post-patch:
${CP} ${FILESDIR}/sanitize.c ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unarj ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- ${INSTALL} -d -m 755 -o ${SHAREOWN} -g ${SHAREGRP} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/unarj ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>